HDU2602 Bone Collector 【01背包】

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 28365    Accepted Submission(s): 11562
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?

HDU2602 Bone Collector 【01背包】

 
Input
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 
Sample Output
14

01背包入门题。

#include <stdio.h>
#include <string.h>
#define maxn 1002 int dp[maxn], w[maxn], v[maxn]; int main()
{
int t, n, val, i, j;
scanf("%d", &t);
while(t--){
scanf("%d%d", &n, &val);
for(i = 1; i <= n; ++i) scanf("%d", v + i);
for(i = 1; i <= n; ++i) scanf("%d", w + i);
memset(dp, 0, sizeof(dp));
for(i = 1; i <= n; ++i){
for(j = val; j >= w[i]; --j){
if(dp[j] < dp[j-w[i]] + v[i])
dp[j] = dp[j-w[i]] + v[i];
}
}
printf("%d\n", dp[val]);
}
return 0;
}
上一篇:oracle性能诊断艺术-执行计划


下一篇:<转>Npoi导入导出Excel操作<载>