题目链接http://acm.hdu.edu.cn/showproblem.php?pid=2602
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2^31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14
题目大意是这样的,给你t组数据,n个数和体积为v的背包,接下来n个数,第一行为价值,第二行为体积,让你求该背包状态下的能获得的最大价值。
。。。本人蒟蒻,菜的抠脚,从来没写过dp,都是让队友写的,现在心中悔恨交加,只好在这老龄之时学一波01背包了。。。。
01背包,简单来讲就是放与不放的问题,我们可以用一个数组来存在体积为i的情况下背包的最大价值,其方程就是:dp[i]=max(此物不放的价值,此物放的价值);
规定a为价值,b为体积,则方程为:dp[j] = max(dp[j], dp[j - b[i]] + a[i]);
于是内部的循环也就出来了:
for (int i = 1; i <= n; i++) {
for (int j = v; j >=b[i]; j--) {
dp[j] = max(dp[j], dp[j - b[i]] + a[i]);
}
}
也就是对第i个物品,枚举体积为v到b[i]时该背包能够获得的最大价值。当然,此为滚动数组,为了取上一次的状态,我们必须将重量倒着枚举(即for (int j = v; j >=b[i]; j–))。
如果是正着枚举的话,就会将这一次的结果重复,即多次选择该物品。
于是核心代码出来了,这题也就结束了。。。
#include <cstdio>
#include <cstring>
using namespace std;
int a[1020], b[1020], c[1020];
int max(int a, int b)
{
return a > b ? a : b;
}
int main()
{
int t, n, v;
scanf("%d", &t);
while (t--) {
scanf("%d%d", &n, &v);
memset(c, 0, sizeof(c));
for (int i = 1; i <= n; i++) {
scanf("%d", &a[i]);
}
for (int i = 1; i <= n; i++) {
scanf("%d", &b[i]);
}
for (int i = 1; i <= n; i++) {
for (int j = v; j >=b[i]; j--) {
c[j] = max(c[j], c[j - b[i]] + a[i]);
}
}
printf("%d\n", c[v]);
}
return 0;
}