数据结构实验之二叉树七:叶子问题
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。
Input
输入数据有多行,每一行是一个长度小于50个字符的字符串。
Output
按从上到下从左到右的顺序输出二叉树的叶子结点。
Sample Input
abd,,eg,,,cf,,,
xnl,,i,,u,,
Sample Output
dfg
uli
#include <stdio.h>
#include <stdlib.h>
struct node
{
char c;
struct node *lt, *rt;
};
char s[100];
int i;
struct node *creat()
{
struct node *root;
if(s[i]==','){
root=NULL;
i++;
}
else{
root=(struct node *)malloc(sizeof(struct node));
root->c=s[i++];
root->lt=creat();
root->rt=creat();
}
return root;
}
void yezi(struct node *root)
{
int out=0,in=0;
struct node *q[100];
q[in++]=root;
while(out<in)
{
if(q[out]){
if(!q[out]->lt&&!q[out]->rt)
printf("%c",q[out]->c);
q[in++]=q[out]->lt;
q[in++]=q[out]->rt;
}
out++;
}
}
int main()
{
while(~scanf("%s",s)){
i=0;
struct node *root;
root=creat();
yezi(root);
printf("\n");
}
return 0;
}