SDUT 3346 数据结构实验之二叉树七:叶子问题

数据结构实验之二叉树七:叶子问题

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。

Input

 输入数据有多行,每一行是一个长度小于50个字符的字符串。

Output

 按从上到下从左到右的顺序输出二叉树的叶子结点。

Example Input

abd,,eg,,,cf,,,
xnl,,i,,u,,

Example Output

dfg
uli

DQE:

水题
 
 #include <iostream>
 #include <cstdio>

 using namespace std;

 struct Tree
 {
     char c;
     Tree *lt,*rt;
 };

 Tree *creat(char *&xx)
 {
     if(*xx=='\0')
         return NULL;
     if(*xx==',')
     {
         xx++;
         return NULL;
     }
     Tree *r=new Tree;
     r->c=*xx++;
     r->lt=creat(xx);
     r->rt=creat(xx);
     return r;
 }

 void cxvisit(Tree *r)
 {
     Tree *que[];
     ,j=;
     que[j++]=r;
     while(i<j)
     {
         if(que[i])
         {
             que[j++]=que[i]->lt;
             que[j++]=que[i]->rt;
             if(que[i]->lt==NULL&&que[i]->rt==NULL)
                 printf("%c",que[i]->c);
         }
         i++;
     }
 }

 int main()
 {
     ],*p;
     Tree *root;
     while(scanf("%s",xx)!=EOF)
     {
         p=xx;
         root=creat(p);
         cxvisit(root);
         printf("\n");
     }
     ;
 }

 /***************************************************
 User name: ***
 Result: Accepted
 Take time: 0ms
 Take Memory: 156KB
 Submit time: 2016-11-03 18:43:40
 ****************************************************/
上一篇:SDUT 3311 数据结构实验之串三:KMP应用


下一篇:SDUT 2141 【TEST】数据结构实验图论一:基于邻接矩阵的广度优先搜索遍历