Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
Output
对于每组输入数据,输出一行,结果保留两位小数。
Sample Input
0 0 0 1
0 1 1 0
Sample Output
1.00
1.41
计算两点之间的距离,注意结果保留两位小数
#include<stdio.h>
#include<math.h>
int main()
{
double a,b,c,d,L;
while(scanf("%lf %lf %lf %lf",&a,&b,&c,&d)!=EOF)
{
L=(c-a)*(c-a)+(d-b)*(d-b);
printf("%.2lf\n",sqrt(L));
}
return ;
}