HDU 2602 Bone Collector 0/1背包

题目链接:

pid=2602">HDU 2602 Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 28903    Accepted Submission(s): 11789

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?

HDU 2602 Bone Collector 0/1背包

 
Input
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 
Sample Output
14
 
Author
Teddy
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:  1203 2159 2955 2844 1087 
 

经典0/1背包问题。

有N件物品和一个容量为V的背包,第i件物品的体积为v[i],价值为w[i],求解将哪些物品装入背包才干使总价值最大。

这是最基础的背包问题,每种物品仅仅有一件。且仅仅有两种状态:放与不放。

用子问题定义状态:dp[i][v]表示前i件物品恰好放入一个容量为m的包中可获得的最大价值。

状态转移方程:dp[i][m] = max(dp[i-1][m], dp[i-1][m-v[i]]+w[i]);

可转化为一维情况:dp[m] = max(dp[m], dp[m-v[i]]+w[i]);

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std; int n, v, dp[1010], value[1010], volume[1010];
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
scanf("%d%d", &n, &v);
for(int i = 1; i <= n; i++)
scanf("%d", &value[i]);
for(int i = 1; i <= n; i++)
scanf("%d", &volume[i]);
memset(dp, 0, sizeof(dp));
for(int i = 1; i <= n; i++)
for(int j = v; j >= volume[i]; j--)
dp[j] = max(dp[j], dp[j-volume[i]]+value[i]);
printf("%d\n", dp[v]);
} return 0;
}
上一篇:XML文档的创建


下一篇:Java解析XML文档(简单实例)——dom解析xml