The following is from Max Howell @twitter:
Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.
Now it’s your turn to prove that YOU CAN invert a binary tree!
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree — and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.
Sample Input:
8
1 –
– –
0 –
2 7
– –
– –
5 –
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1
生词
英文 | 解释 |
---|---|
indices | index的复数 |
题目大意:
反转一棵二叉树,给出原二叉树的每个结点的左右孩子,输出它的层序和中序遍历~
分析:
- 反转二叉树就是存储的时候所有左右结点都交换。
- 二叉树使用{id, l, r, index, level}存储每个结点的id, 左右结点,下标值,和当前层数~
- 根结点是所有左右结点中没有出现的那个结点~
- 已知根结点,用递归的方法可以把中序遍历的结果push_back到数组v1里面,直接输出就是中序,排序输出就是层序(排序方式,层数小的排前面,相同层数时,index大的排前面)
原文链接:https://blog.csdn.net/liuchuo/article/details/52175736
题解
#include <bits/stdc++.h>
using namespace std;
const int maxn=110;
struct Node
{
int lchild,rchild;
}node[maxn];
bool notRoot[maxn];
int n,num=0;
int strToNum(char c){
if(c=='-') return -1;
else{
notRoot[c-'0']=true;
return c-'0';
}
}
int findRoot(){
for(int i=0;i<n;i++){
if(notRoot[i]==false)
return i;
}
}
void print(int id){
cout<<id;
num++;
if(num<n) cout<<" ";
else cout<<endl;
}
void postOrder(int root){
if(root==-1) return;
postOrder(node[root].lchild);
postOrder(node[root].rchild);
swap(node[root].lchild,node[root].rchild);
}
void BFS(int root){
queue<int> q;
q.push(root);
while(!q.empty()){
int now=q.front();
q.pop();
print(now);
if(node[now].lchild!=-1) q.push(node[now].lchild);
if(node[now].rchild!=-1) q.push(node[now].rchild);
}
}
void inOrder(int root){
if(root==-1) return;
inOrder(node[root].lchild);
print(root);
inOrder(node[root].rchild);
}
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("1.txt", "r", stdin);
#endif
char lchild,rchild;
scanf("%d",&n);
for(int i=0;i<n;i++){
//getchar();
scanf("%*c%c %c",&lchild,&rchild);
node[i].lchild=strToNum(lchild);
node[i].rchild=strToNum(rchild);
}
int root=findRoot();
postOrder(root);
BFS(root);
num=0;
inOrder(root);
return 0;
}