Proving Equivalences (强连通,缩点)

目录

Proving Equivalences (强连通,缩点)

题目

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

  1. A is invertible.
  2. Ax = b has exactly one solution for every n × 1 matrix b.
  3. Ax = b is consistent for every n × 1 matrix b.
  4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
  • m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output
Per testcase:

  • One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input
2
4 0
3 2
1 2
1 3
Sample Output
4
2

题意

给出n个点和m条边,问最少须添加多少个边,使得任意两点间能互通。给出的m条边是有向的。

思路

先求出强连通分量kk个,并把每个强连通重新编号为1至kk。再计算出新点的入度数与出度数,最终须要添加的边数就是 入度数为0的个数与出度数为0的个数之间最大的数。

题解

#include <cstdio>
#include <algorithm>
#include <string.h>
#include <vector>
#include <iostream>
#include <stack>
#define N 20004
using namespace std;
vector<int> eg[N];
stack<int> sk;
int idx = 0;
int dfn[N], low[N], ins[N], block[N], in[N], out[N], cnt = 0;
int n, m, x, y;
void tarjan(int u)
{
    dfn[u] = low[u] = ++idx;
    sk.push(u);
    ins[u] = 1;
    for (int v : eg[u])
    {
        if (!dfn[v])
        {
            tarjan(v);
            low[u] = min(low[u], low[v]);
        }
        else if (ins[v])
        {
            low[u] = min(low[u], dfn[v]);
        }
    }
    int tem;
    if (dfn[u] == low[u])
    {
        cnt++;
        do
        {
            tem = sk.top();
            sk.pop();
            block[tem] = cnt;
            ins[tem] = 0;
        } while (tem != u);
    }
}

void slove()
{
    if(cnt==1)
    {
        cout<<0<<endl;
        return;
    }

    for (int i = 1; i <= n; i++)//缩点
    {
        for (int v : eg[i])
        {

            if (block[v] != block[i])
            {
                out[block[i]]++;
                in[block[v]]++;
            }
        }
    }
    int resi=0, reso=0;
    for (int i = 1; i <= cnt; i++)//统计
    {
        if (in[i] == 0)
            resi++;
        if (out[i] == 0)
            reso++;
    }
    cout << max(resi, reso) << endl;
}

void init()
{
    memset(in, 0, sizeof(in));
    memset(out, 0, sizeof(out));
    memset(block, 0, sizeof(block));
    memset(ins, 0, sizeof(ins));
    memset(low, 0, sizeof(low));
    memset(dfn, 0, sizeof(dfn));
}

int main()
{
    int T;
    cin >> T;
    while (T--)
    {
        init();

        cin >> n >> m;
        for (int i = 1; i <= m; i++)
        {
            cin >> x >> y;
            eg[x].push_back(y);
        }
        cnt = 0;
        idx = 0;
        for (int i = 1; i <= n; i++)
            if (!dfn[i])
                tarjan(i);

        slove();
        for (int i = 1; i <= n; i++)
            eg[i].clear();
    }
}
上一篇:牛客多校第一场 A Equivalent Prefixes 单调栈(笛卡尔树)


下一篇:ActiveMQ教程(消息发送和接受)