Best Cow Line / POJ - 3617

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

题意

多组测试数据
给你一个长度为N的字符串S,输入格式是依次输入N个字符
N <= 2000
每次你可以从S的开头或者结尾取出一个字符,放到一个T字符串的尾部
输出字典序最小的T字符串,每80个字符换一行输出

题解

每次比较左右2端的字符大小,哪个小选哪个,如果一样,那么再往里搜,要是都一样,随意输出一个即可(我是输出啦最后的一个)

代码

#include<iostream>
#include<string> 
#include<cstdio>
using namespace std; 

int n;
char s[2010]; 

int main(){
    scanf("%d", &n);
    for(int i = 0; i < n; i++){
        scanf("%s", &s[i]);
    }
    //左端 右端的下标,count记录当前数目 于80时换行
    int start = 0, end = n - 1,count = 0;
    while(start <= end){
        for(int i = 0; i*2 <= end - start; i++){
            if(s[start+i] < s[end-i]){//哪个小选哪个
               printf("%c", s[start++]);
               count++;
               break;
            }else if(s[start+i] > s[end-i]){//同上
                printf("%c", s[end--]);
                count++;
                break;
            }
            if(i*2 == end - start || i*2 == end - start - 1){//说明遍历到最后 都是一样的 那么输出最后一个
                printf("%c", s[end--]);
                break;
            }
        }
        if(count % 80 == 0){//满80 换行
            printf("\n");
        }
    }
    return 0;
}
PS

上面的代码也可以这样写,emm……

上一篇:H - Cow Contest POJ - 3660


下一篇:题解【洛谷P1522】牛的旅行 Cow Tours