HDU-1019 Least Common Multiple

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output
105
10296

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
int gcd(int a,int b){
    if(b==0) return a;
    return gcd(b,a%b);
}
int main(){
    int t; scanf("%d",&t);
    while(t--) {
        int n; scanf("%d",&n);
        int a=1,cnt=1,x;
        for(int i=1;i<=n;i++){
        	scanf("%d",&x);
            cnt=a/gcd(a,x)*x;//先除后乘,避免溢出
            a=cnt;
        }
        printf("%d\n",a);
    }
    return 0;
}
上一篇:斗地主算法判断牌型


下一篇:单例模式