题目
在一个3×3的网格中,1~8这8个数字和一个“x”恰好不重不漏地分布在这3×3的网格中。
例如:
1 2 3
x 4 6
7 5 8
在游戏过程中,可以把“x”与其上、下、左、右四个方向之一的数字交换(如果存在)。
我们的目的是通过交换,使得网格变为如下排列(称为正确排列):
1 2 3
4 5 6
7 8 x
例如,示例中图形就可以通过让“x”先后与右、下、右三个方向的数字交换成功得到正确排列。
交换过程如下:
1 2 3 1 2 3 1 2 3 1 2 3
x 4 6 4 x 6 4 5 6 4 5 6
7 5 8 7 5 8 7 x 8 7 8 x
现在,给你一个初始网格,请你求出得到正确排列至少需要进行多少次交换。
输入格式
输入占一行,将3×3的初始网格描绘出来。
例如,如果初始网格如下所示:
1 2 3
x 4 6
7 5 8
则输入为:1 2 3 x 4 6 7 5 8
输出格式
输出占一行,包含一个整数,表示最少交换次数。
如果不存在解决方案,则输出”-1”。
输入样例:
2 3 4 1 5 x 7 6 8
输出样例
19
前置知识
康托展开\(\sum_{i=0}^{n-1}d[i]*i!\)
这道题目主要的难点就是判断重复,显然直接判断矩阵最坏情况是比较\(9^4\)次,如此暴力判断重复不可行,故使用字符串存储数码,然后使用康托展开来判断重复。
实现
#include <bits/stdc++.h>
using namespace std;
const int N = 20;
bool vis[362880]; //362879 is ok
int fact[10]; //9 is ok
int dx[5]={0,0,0,1,-1};
int dy[5]={0,-1,1,0,0};
typedef struct{
char s[12];
int k; //k is the postion of x
int step;
}Point;
int permutation_hash(char *a,int n){
int ans=0,d;
for(int i=0;i<n;i++){
d=0;
for(int j=0;j<i;j++){
if(a[j]>a[i])d++;
}
ans+=d*fact[i];
}
return ans;
}
void init_fact(){
fact[0]=1;
for(int i=1;i<=9;i++)fact[i]=fact[i-1]*i;
}
bool check(int x,int y){
if(x >= 0 && x <= 2 && y >= 0 && y <= 2)return true;
return false;
}
int bfs(Point p){
vis[permutation_hash(p.s,9)]=true;
queue<Point> Q;
Q.push(p);
while(!Q.empty()){
p=Q.front();
Q.pop();
if(!strcmp(p.s,"12345678x")) return p.step;
int x = p.k/3;
int y = p.k%3;
Point ret;
ret.step=p.step+1;
for(int i=1;i<=4;i++){
int nx=x+dx[i],ny=y+dy[i];
if(check(nx,ny)){
ret.k=nx*3+ny;
strcpy(ret.s, p.s);
ret.s[9] = 0;
ret.s[p.k] = p.s[ret.k];
ret.s[ret.k] = 'x';
int hash = permutation_hash(ret.s,9);
if(!vis[hash]){
vis[hash] = true;
Q.push(ret);
}
}
}
}
return -1;
}
int main(){
init_fact();
char c[2];
Point start;
for(int i = 0; i < 9; i ++){
scanf("%s",&c);
if(c[0] == 'x') start.k = i;
start.s[i] = c[0];
}
start.s[9] = 0;
start.step = 0;
printf("%d",bfs(start));
return 0;
}
TODO
尝试使用双向广搜,IDA*,A*算法实现优化。链接——八数码(八境界)