1011 World Cup Betting (20 分)

1011 World Cup Betting (20 分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner‘s odd would be the product of the three odds times 65%.

For example, 3 games‘ odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%?1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

思路

1.找出三局的最大数a,b,c,利润就是(a×b×c×65%?1)×2

代码

#include<stdio.h>
#include<string.h>
double Thebigest(double a, double b, double c){
	if( (a > b) && (a > c)) return a;
	else if(b > c) return b;
	else return c;
}
int main(){
	char s[4] = {};
	double a, b, c;
	for(int i = 0; i < 3; i++){
		double temp;
		double w, t, l; 
		scanf("%lf%lf%lf", &w, &t, &l);
		temp = Thebigest(w,t,l);
		if(temp == w) s[i] = ‘W‘;
		else if(temp == t) s[i] = ‘T‘;
		else s[i] = ‘L‘; 
		if(i == 0) a = temp;
		else if(i == 1) b = temp;	
		else c = temp;
	}
	
	for(int i = 0; i < 3; i++){
		printf("%c ",s[i]);
	}
	printf("%.2lf", (a * b * c * 0.65 - 1) * 2);
	return 0;
} 

参考代码

1.二维数组ixj,可以分开行序列和列序列

#include<cstdio>
char s[3] = {‘W‘,‘T‘,‘L‘};
int main(){
    double ans = 1.0, tmp, a;
    int idx;
    for(int i = 0; i < 3; i++){
		tmp = 0.0;
        for(int j = 0; j < 3; i++){
			scanf("%lf", &a);
            if(a > tmp){
                tmp = a;
                idx = j;
            }
        }
        ams *= tmp;
        printf("%c ", s[idx]);
    }
    printf("%.2f", (ans * 0.65 - 1) * 2);
    return 0;
}

1011 World Cup Betting (20 分)

上一篇:接口的三种写法


下一篇:使用el-select时选中值改变但没有渲染变化