1027 Colors in Mars (20 分)_20行代码AC

立志用最少的代码做最高效的表达


PAT甲级最优题解——>传送门


People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:
15 43 71

Sample Output:
#123456


简单进制处理,水题。 因此重心转化为如何优化代码结构和效率。 具体见实现代码。

注意大写字母和前导0


#include<bits/stdc++.h>
using namespace std;

char a[13] = {'0','1','2','3','4','5','6','7','8','9','A','B','C'};

string redix(int n) {
	string s;
	while(n) {
		s += a[n%13];
		n /= 13;
	}
	reverse(s.begin(),s.end());
	return s;
} 

int main()  {
	putchar('#');
	for(int i = 0; i < 3; i++) {
		int a; cin >>a; 
		cout << setfill('0') << setw(2) <<  redix(a);
	}
	return 0 ;
}

耗时:

1027 Colors in Mars (20 分)_20行代码AC


        ——痛苦难道是白忍受的吗?他应该使我伟大!

上一篇:PAT 1027 Colors in Mars


下一篇:蓝桥试题 算法提高 P0101 JAVA