1、域间汇总、域外汇总解析
2、实验拓扑
3、实验配置
R1配置
interface Loopback0
ip address 1.1.1.1 255.255.255.0
interface Serial0/0
ip address 12.1.1.1 255.255.255.0
interface FastEthernet1/0
ip address 120.1.1.1 255.255.255.0
router ospf 110
router-id 8.8.8.1
network 1.1.1.0 0.0.0.255 area 0
network 12.1.1.0 0.0.0.255 area 0
network 120.1.1.0 0.0.0.255 area 0
R2配置
interface Loopback0
ip address 2.2.2.2 255.255.255.0
interface Serial0/0
ip address 12.1.1.2 255.255.255.0
interface Serial0/1
ip address 23.1.1.2 255.255.255.0
interface FastEthernet1/0
ip address 120.1.1.2 255.255.255.0
router ospf 110
router-id 8.8.8.2
network 2.2.2.0 0.0.0.255 area 0
network 12.1.1.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 1
network 120.1.1.0 0.0.0.255 area 0
R3配置
interface Loopback0
ip address 3.3.3.3 255.255.255.0
interface Serial0/0
ip address 34.1.1.3 255.255.255.0
interface Serial0/1
ip address 23.1.1.3 255.255.255.0
router ospf 110
router-id 8.8.8.3
redistribute rip subnets
network 3.3.3.0 0.0.0.255 area 1
network 23.1.1.0 0.0.0.255 area 1
router rip
version 2
network 34.0.0.0
no auto-summary
R4配置
interface Loopback0
ip address 4.4.4.4 255.255.255.0
interface Serial0/0
ip address 34.1.1.4 255.255.255.0
router rip
version 2
network 4.0.0.0
network 34.0.0.0
no auto-summary
4、域间汇总
在R3上建立四个环回口,并宣告进Area1
1o16:192.168.16.1/24
1o17:192.168.17.1/24
1o18:192.168.18.1/24
1o19:192.168.19.1/24
R3配置
interface Loopback16
ip address 192.168.16.1 255.255.255.0
interface Loopback17
ip address 192.168.17.1 255.255.255.0
interface Loopback18
ip address 192.168.18.1 255.255.255.0
interface Loopback19
ip address 192.168.19.1 255.255.255.0
router ospf 110
router-id 8.8.8.3
network 192.168.16.0 0.0.0.255 area 1
network 192.168.17.0 0.0.0.255 area 1
network 192.168.18.0 0.0.0.255 area 1
network 192.168.19.0 0.0.0.255 area 1
注:域间汇总要在本局域内的所有ABR上进行汇总。
5、域外汇总
在R4上建立四个环回口,并宣告进RIP
1o16:10.10.16.1/24
1o17:10.10.17.1/24
1o18:10.10.18.1/24
1o19:10.10.19.1/24
R4配置
interface Loopback16
ip address 10.10.16.1 255.255.255.0
interface Loopback17
ip address 10.10.17.1 255.255.255.0
interface Loopback18
ip address 10.10.18.1 255.255.255.0
interface Loopback19
ip address 10.10.19.1 255.255.255.0
router rip
network 10.0.0.0
汇总前