Number Sequence 分类: HDU 2015-06-19 20:54 10人阅读 评论(0) 收藏

Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 124827 Accepted Submission(s): 30331

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3 1 2 10 0 0 0

Sample Output

2 5

数据很大,所以肯定有循环节

#include <iostream>
#include <cstdio>
using namespace std;
int Arr[10000];
int main()
{
int a,b,i;
int n;
Arr[1]=1;
Arr[2]=1;
while(cin>>a>>b>>n)
{
if(!a&&!b&&!n)
{
break;
}
for( i=3; i<10000; i++)
{
Arr[i]=(a*Arr[i-1]+b*Arr[i-2])%7;
if(Arr[i]==1&&Arr[i-1]==1)
{
break;
}
}
n=n%(i-2);
Arr[0]=Arr[i-2];
cout<<Arr[n]<<endl;
}
return 0; }

版权声明:本文为博主原创文章,未经博主允许不得转载。

上一篇:jmeter(四十四)常用性能指标分析


下一篇:Win8/Win10下程序经常无响应的解决办法