【CF670C】Cinema

题目描述

Moscow is hosting a major international conference, which is attended by \(n\) scientists from different countries. Each of the scientists knows exactly one language. For convenience, we enumerate all languages of the world with integers from \(1\) to \(10^9\) .

In the evening after the conference, all n n n scientists decided to go to the cinema. There are m m m movies in the cinema they came to. Each of the movies is characterized by two distinct numbers — the index of audio language and the index of subtitles language. The scientist, who came to the movie, will be very pleased if he knows the audio language of the movie, will be almost satisfied if he knows the language of subtitles and will be not satisfied if he does not know neither one nor the other (note that the audio language and the subtitles language for each movie are always different).

Scientists decided to go together to the same movie. You have to help them choose the movie, such that the number of very pleased scientists is maximum possible. If there are several such movies, select among them one that will maximize the number of almost satisfied scientists.

传送门

输入输出格式

输入格式:

The first line of the input contains a positive integer \(n\) ( 1<=n<=200000 1<=n<=200000 1<=n<=200000 ) — the number of scientists.

The second line contains \(n\) positive integers \(a_1,a_2,...,a_n ( 1<=a_i<=10^9 )\), where \(a_i\) is the index of a language, which the \(i\) -th scientist knows.

The third line contains a positive integer \(m ( 1<=m<=200000 )\) — the number of movies in the cinema.

The fourth line contains \(m\) positive integers \(b_1,b_2,...,b_m ( 1<=b_j<=10^9 )\), where \(b_j\) is the index of the audio language of the \(j\) -th movie.

The fifth line contains \(m\) positive integers \(c_1,c_2,...,c_m ( 1<=c_j<=10^9 )\), where \(c_j\) is the index of subtitles language of the \(j\) -th movie.

It is guaranteed that audio languages and subtitles language are different for each movie, that is \(b_j≠c_j\) .

输出格式:

Print the single integer — the index of a movie to which scientists should go. After viewing this movie the number of very pleased scientists should be maximum possible. If in the cinema there are several such movies, you need to choose among them one, after viewing which there will be the maximum possible number of almost satisfied scientists.

If there are several possible answers print any of them.

输入输出样例:

输入样例#1:

3
2 3 2
2
3 2
2 3

输入样例#2:

6
6 3 1 1 3 7
5
1 2 3 4 5
2 3 4 5 1

输出样例#1:

2

输出样例#2:

1

分析

直接在所有电影中,找出配音语言有最多人会的电影,但这种电影可能有多部,于是再在这些电影中找出字幕语言有最多人会的电影即可。

怎么知道哪种语言有多少人会呢?我们可以离散化处理,由于这题的数据有\(10^9\)之大,所以需要用map,否则会MLE。

至于找出最多人会的语言,我一开始用的排序,奈何数据过于毒瘤,卡在第125个数据点过不去,试了试手动开\(o_2\),仍然过不了。。。。。。于是只好放弃sort,手动找了。

代码

//#pragma GCC optimize(2)
#include<cstdio>
#include<algorithm>
#include<map>
using namespace std;
struct cinema{
    int cv,av;  //cv是配音,av是字幕,别想歪了(滑稽) 
}film[200001];
int n,m;
map<int,int>Cthollist;  //珂学家们 
/*bool cmp(const cinema& a,const cinema& b){    //一开始用的排序
    return Cthollist[a.cv]==Cthollist[b.cv] ? Cthollist[a.av]>Cthollist[b.av] : Cthollist[a.cv]>Cthollist[b.cv];
} */
int main(){
    int k,res,max1=-1,max2=-1;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)   scanf("%d",&k),Cthollist[k]++;
    scanf("%d",&m);
    for(int i=1;i<=m;i++)   scanf("%d",&film[i].cv);
    for(int i=1;i<=m;i++)   scanf("%d",&film[i].av);
    //sort(film+1,film+1+m,cmp);
    for(int i=1;i<=m;i++){
        if(Cthollist[film[i].cv]>max1){
            max1=Cthollist[film[i].cv];
            max2=Cthollist[film[i].av];
            res=i;
        }
        else if(Cthollist[film[i].cv]==max1){
            if(Cthollist[film[i].av]>max2){
                max2=Cthollist[film[i].av];
                res=i;
            }
        }
    }
    printf("%d",res);
    //printf("%d",film[1].num);
    return 0;
}
上一篇:Day02---requests请求库爬取豆瓣电影信息


下一篇:豌豆荚