题目描述:
Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1000000).
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
Sample Input
0
1
2
3
4
5
Sample Output
no
no
yes
no
no
no
这个题目的关键!!!应该想到会不会超时的问题。所以应该定义一个返回值为void的函数Fibonacci,函数体内直接算出由0到1000001内的数,这里题目只是判断是不是3的倍数,所以就可以将每次算出来的结果取余3,进行这个操作就不会超时了。
其他要注意的:要定义一个全局数组f[1000001],主函数体内调用函数Fibonacci,再判断f[x]%3是否为0,即可。
代码:
#include <iostream>
using namespace std;
int f[1000001];
void Fibonnacci()
{
f[0] = 7;
f[1] = 11;
for (int i = 2; i < 1000001; i++)
f[i] = (f[i - 1] + f[i - 2]) % 3;
}
int main()
{
Fibonnacci();
int n;
while (cin >> n) {
if (f[n] % 3 == 0)
cout << "yes" << endl;
else
cout << "no" << endl;
}
return 0;
}