ACM题目 1032: [编程入门]自定义函数之字符串连接
题目描述
写一函数,将两个字符串连接
输入
两行字符串
输出
链接后的字符串
样例输入
123
abc
样例输出
123abc
答案:
#include <stdio.h>
int main()
{
char s1[200],s2[200];
int i=0,j=0;
scanf("%s",s1);
scanf("%s",s2);
while (s1[i]!='\0')
i++;
while(s2[j]!='\0')
s1[i++]=s2[j++];
s1[i]='\0';
printf("%s\n",s1);
return 0;
}