【SQL Server DBA】日常巡检2:windows性能监控器


The Blocks Problem

Background

Many areas of Computer Science use simple, abstract domains  for both analytical and empirical studies.  For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks. 

In this problem you will model a simple block world under certain rules and constraints.  Rather than determine how to achieve a specified state, you will ``program‘‘ a robotic arm to respond to a limited set of commands.

The Problem

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table.  Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1for all 【SQL Server DBA】日常巡检2:windows性能监控器as shown in the diagram below:
【SQL Server DBA】日常巡检2:windows性能监控器
Figure:Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

    where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions. 

  • move a over b

    where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consisting of block a,  and any blocks that are stacked above block a, onto block b.  All blocks on top of block b are moved to their initial positions prior to the pile taking place.  The blocks stacked above blocka retain their order when moved.

  • pile a over b

    where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above  block a, onto the top of the stack containing block b.  The blocks stacked above blocka retain their original order when moved. 

  • quit

    terminates manipulations in the block world.

Any command in which a = b or in which a and bare in the same stack of blocks is an illegal command.  All illegal commands should be ignored and should have no affect on the configuration of blocks.

The Input

The input begins with an integer n on a line by itself representing the number of blocks in the block world.  You may assume that 0 < n < 25.

The number of blocks is followed by a sequence of block commands, one command per line.  Your program should process all commands until the quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output

The output should consist of the final state of the blocks world.  Each original block position numbered i  (【SQL Server DBA】日常巡检2:windows性能监控器where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of  blocks that appear stacked in that position with each block number  separated from other block numbers by a space. Don‘t put any trailing  spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the  integer on the first line of input).

Sample Input

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output

 0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:



Miguel Revilla
2000-04-06

 

 

 

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <stack>
using namespace std;

const int MAX = 50;

int n;
stack<int> s[MAX];
int number[MAX];

void back_blocks(int a, int value)
{
	int temp;
	while(!s[a].empty())
	{
		temp =s[a].top();
		if(temp==value) break;
		s[temp].push(temp);
		number[temp] = temp;
		s[a].pop();
	}
}

void solve_move_onto(int left , int right)
{
	int a = number[left];
	int b = number[right];
	
	if(s[a].size()>1)
		back_blocks(a, left);
	if(s[b].size()>1)
		back_blocks(b, right);
	
	int temp = s[a].top();
	s[b].push(temp);
	number[temp] = b;
	s[a].pop();
}

void solve_move_over(int left, int right)
{
	int a = number[left];
	int b = number[right];
	
	if(s[a].size()>1)
		back_blocks(a, left);

	int temp = s[a].top();
	s[b].push(temp);
	number[temp] = b;
	s[a].pop();
}

void solve_pile_onto(int left , int right)
{
	int a = number[left];
	int b = number[right];
	
	if(s[b].size()>1)
		back_blocks(b, right);
	
	int num[MAX],length=0;
	while(!s[a].empty())
	{
		int temp = s[a].top();
		number[temp] = b;
		num[length++] = temp;
		if(temp==left){ s[a].pop();break;}
		s[a].pop();
	}
	for(int i=length-1; i>=0; i--)
		s[b].push(num[i]);
}

void solve_pile_over(int left, int right)
{
	int a = number[left];
	int b = number[right];
	
	int num[MAX], length=0;
	int temp;
	while(!s[a].empty())
	{
		temp = s[a].top();
		num[length++] = temp;
		number[temp] = b;
		if(temp==left) { s[a].pop();break;}
		s[a].pop();
	}
	for(int i=length-1; i>=0; i--)
		s[b].push(num[i]);
}

void read()
{
	char ch[10];
	char ch2[10];
	int left, right;
	while(scanf("%s", ch))
	{
		if(ch[0]==‘q‘) break;
		
		scanf("%d %s %d", &left, ch2, &right);
		
		if(strcmp(ch,"move")==0)
		{
			if(strcmp(ch2,"onto")==0)
				solve_move_onto(left, right);
			else
				solve_move_over(left , right);
		}else if(strcmp(ch,"pile")==0)
		{
			if(strcmp(ch2, "onto")==0)
				solve_pile_onto(left, right);
			else
				solve_pile_over(left, right);
		}
	}
}

void init()
{
	for(int i=0; i < n; i++)
	{
		s[i].push(i);
		number[i] = i;
	}
}

void output()
{
	int num[MAX], length=0;
	for(int i=0; i < n; i++)
	{
		cout << i << ":";
		length=0;
		while(!s[i].empty())
		{
			num[length++]=s[i].top();
			s[i].pop();
		}
		for(int j=length-1; j>=0; j--)
			cout << " " << num[j];
		cout << endl;
	}
 	cout << endl;
}

int main()
{
//	freopen("in.txt","r",stdin);
	while(scanf("%d", &n)==1)
	{
		init();
		read();
		output();
	}
	return 0;
}


 

【SQL Server DBA】日常巡检2:windows性能监控器,布布扣,bubuko.com

【SQL Server DBA】日常巡检2:windows性能监控器

上一篇:oracle 索引类型


下一篇:oracle dblink 实践详解