ZOJ3767 Elevator 2017-04-13 23:32 37人阅读 评论(0) 收藏

Elevator


Time Limit: 2 Seconds      Memory Limit: 65536 KB

How time flies! The graduation of this year is around the corner. N members of ZJU ACM/ICPC Team decided to hold a party in a restaurant. The restaurant is located in a skyscraper
so they need to take an elevator to reach there.

The elevator's maximum load is M kilograms. The weight of the i-th team member is Ai kilograms. If the total weight of people in the elevator exceeds
the maximum load of the elevator, the elevator will raise the alarm and will not move.

Please write a program to implement the weight detector of the elevator.

Input

There are multiple test cases. The first line of input is an integer T indicates the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 20) and M (1 <= M <= 2000). The next line contains N integers Ai (1
<= Ai <= 500).

Output

For each test case, output "Safe" if no alarm will be raised. Otherwise, output "Warning".

Sample Input

2
3 800
50 60 70
9 800
50 55 60 60 60 60 65 70 360

Sample Output

Safe
Warning

直接把物品加起来判断和限重的大小

#include <iostream>
#include <cstdio>
using namespace std; int main()
{
int T,n,m,sum,a;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
int sum=0;
for(int i=0;i<n;i++)
scanf("%d",&a),sum+=a;
if(sum<=m)
printf("Safe\n");
else
printf("Warning\n");
}
return 0;
}
上一篇:Efficient Deblurring for Shaken and Partially Saturated Images


下一篇:ASP.NET SignaiR 实现消息的即时推送,并使用Push.js实现通知