PAT (Advanced Level) Practice 1155 Heap Paths (30分) (递归+数组建树,递归+vector输出,make_heap判断)

1.题目

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

2.题目分析

1.建树

开始思路跑偏了,一直想着数据结构题库里那个层序遍历输出的题,忘了数据结构老师说过:

完全二叉树按照数组存放的时候,2*i是左子树,2*i+1是右子树 (失败……)

2.输出

vector记录之前的数据,观察发现是遍历(后序遍历)到叶子节点的时候就输出一次,输出后将最后一个删除,再接着遍历 

3.判断

分别使用make_heap建立大根堆、小根堆,以此判断就行

3.代码

#include<iostream>
#include<algorithm>
#include<functional>
#include<vector>
#include<cstdio>
using namespace std;
int list[1001];
typedef struct node * tree;
struct node
{
	int data;
	tree left;
	tree right;
};
tree creat(tree origin,int list[],int i,int n)
{
	if (i > n)return NULL;
	if(!origin)
	origin = (tree)malloc(sizeof(struct node));
	origin->left = origin->right = NULL;
	origin->data = list[i];
	origin->left = creat(origin->left, list, 2 * i,n);
	origin->right = creat(origin->right, list, 2 * i+1, n);
	return origin;
}
void output(tree origin, vector<int>out)
{
	if (!origin)return;
	if (origin->left==NULL&&origin->right==NULL)
	{
		out.push_back(origin->data);
		int size = out.size();
		for (int i = 0; i < size; i++)
			printf("%d%s", out[i], i == size - 1 ? "" : " ");
		printf("\n");
		out.pop_back();
		return;
	}
	out.push_back(origin->data);
    
	output(origin->right, out);
	
	output(origin->left, out);
}
int main()
{
	int n,count=1;
	cin >> n;
	tree origin = (tree)malloc(sizeof(struct node));
	origin->left = origin->right = NULL;
	for (int i = 1; i <=n; i++)
		cin >> list[i];

	origin = creat(origin, list, 1, n);
	vector<int>out;
	output(origin, out);
	vector<int>com;
	for (int i = 1; i <=n; i++)
		com.push_back(list[i]);
	bool big = true;
	make_heap(com.begin(), com.end(), less<int>());
	for (int i = 1; i <= n; i++)
	{
		if (list[i] != com[i - 1]) { big = false; break; }
	}
	if (!big)
	{
		make_heap(com.begin(), com.end(), greater<int>());
		for (int i = 1; i <= n; i++)
		{
			if (list[i] != com[i - 1]) { printf("Not Heap\n"); return 0; }
		}
		printf("Min Heap\n");
	}
	else
		printf("Max Heap\n");
}

甲级加油!

上一篇:lc0306


下一篇:Codeforces Round #615 (Div. 3) F. Three Paths on a Tree(树的直径,dfs)