HDU - 2120 Ice_cream's world I

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded. 
One answer one line.

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

Sample Output

3

题目大意:给了一些墙,问最多能围成几块地,用并查集。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[1010];
int n,m;
int num;
void init()
{
    for(int i=0; i<n; i++)
        f[i]=i;
}
int getf(int v)
{
    if(f[v]==v)
        return v;
    else
        return f[v]=getf(f[v]);
}
int merge(int u,int v)
{
    int t1=getf(u);
    int t2=getf(v);
    if(t1==t2&&u!=v)
         num++;
    else
       f[t2]=t1;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        num=0;
        int a,b;
        init();
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&a,&b);
            merge(a,b);
        }
        printf("%d\n",num);
    }
    return 0;
}

 

上一篇:python库——math模块


下一篇:10nm Ice Lake处理器值得等待!