Description
小约翰经常和他的哥哥玩一个非常有趣的游戏:桌子上有n堆石子,小约翰和他的哥哥轮流取石子,每个人取的时候,可以随意选择一堆石子,在这堆石子中取走任意多的石子,但不能一粒石子也不取,我们规定取到最后一粒石子的人算输。小约翰相当固执,他坚持认为先取的人有很大的优势,所以他总是先取石子,而他的哥哥就聪明多了,他从来没有在游戏中犯过错误。小约翰一怒之前请你来做他的参谋。自然,你应该先写一个程序,预测一下谁将获得游戏的胜利。
Input
本题的输入由多组数据组成,第一行包括一个整数T,表示输入总共有T组数据(T≤500)。每组数据的第一行包括一个整数N(N≤50),表示共有N堆石子,接下来有N个不超过5000的整数,分别表示每堆石子的数目。
Output
每组数据的输出占一行,每行输出一个单词。如果约翰能赢得比赛,则输出“John”,否则输出“Brother”,请注意单词的大小写。
Sample Input
2
3
3 5 1
1
1
Sample Output
John
Brother
HINT
【数据规模】
对于40%的数据,T ≤ 250。
对于100%的数据,T ≤ 500。
//bzoj3245
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <math.h>
#include <map>
#define maxn 600000
using namespace std;
int main()
{
int t,n,a;
scanf("%d",&t);
while(t--)
{
int flag=0,x=0;
a=0;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&a);
x^=a;
if(a!=1)flag=1;
}
if(flag)
{
if(x==0)printf("Brother\n");else printf("John\n");
}
else
{
if((n&1)==0)printf("John\n");else printf("Brother\n");
}
}
return 0;
}