Super Jumping! Jumping! Jumping! 最长上升子序列+DP

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
Super Jumping! Jumping! Jumping! 最长上升子序列+DP
The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each case, print the maximum according to rules, and one line one case.
Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0
Sample Output
4
10
3

最长子序列的同款题目,这次求的不是最长子序列的长度,而是最长子序列的和,只需要把最长子序列模板的值做一下修改,一般情况下dp数组的值是在自己之前的最长子序列的长度,这里换为在自己之前的最长子序列的和即可。

AC代码

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int dp[1005];
int num[1005];
int main()
{
	int n;
	while(cin>>n&&n)
	{
		int maxl=-1;
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
			cin>>num[i];
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<i;j++)
				if(num[i]>num[j])
					dp[i]=max(dp[i],dp[j]+num[i]);
			
			if(dp[i]==0) dp[i]=num[i];
			if(maxl<dp[i]) maxl=dp[i];
		}
		cout<<maxl<<endl;
	}
	return 0;
}
上一篇:Super Jumping! Jumping! Jumping!(dp 水题)


下一篇:[kuangbin带你飞]专题十二 基础DP1 E - Super Jumping! Jumping! Jumping! HDU - 1087