海战
题目描述
在峰会期间,武装部队得处于高度戒备。警察将监视每一条大街,军队将保卫建筑物,领空将布满了F-2003飞机。此外,巡洋船只和舰队将被派去保护海岸线。不幸的是因为种种原因,国防海军部仅有很少的几位军官能指挥大型海战。因此,他们考虑培养一些新的海军指挥官,他们选择了“海战”游戏来帮助学习。
在这个著名的游戏中,在一个方形的盘上放置了固定数量和形状的船只,每只船却不能碰到其它的船。在这个题中,我们仅考虑船是方形的,所有的船只都是由图形组成的方形。编写程序求出该棋盘上放置的船只的总数。
输入
输入文件头一行由用空格隔开的两个整数R和C组成,1<=R,C<=1000,这两个数分别表示游戏棋盘的行数和列数。接下来的R行每行包含C个字符,每个字符可以为“#”,也可为“.”,“#”表示船只的一部分,“.”表示水。
输出
为每一个段落输出一行解。如果船的位置放得正确(即棋盘上只存在相互之间不能接触的方形,如果两个“#”号上下相邻或左右相邻却分属两艘不同的船只,则称这两艘船相互接触了)。就输出一段话“There are S ships.”,S表示船只的数量。否则输出“Bad placement.”。
样例输入
6 8
…#.#
##…#
##…#
…#
#…#
#…#…#
样例输出
There are 5 ships.
AC代码
代码如下(示例):
#include <bits/stdc++.h>
#include <queue>
using std::cin;
using std::cout;
using std::endl;
using std::queue;
int m, n;
int s[6][2] = {-1, 0, 0, -1, 0, 1, 1, 0, 0, 0, 1, 1};//左上右下及yuandi右上
char ar[500][500];
int arr[500][500];
int cnt = 0;
queue<int> q;
bool fang(int sx, int sy)
{
int count = 0;
for (int i = 2; i < 6; i++)
{
if (arr[sx + s[i][0]][sy + s[i][1]] == '#')
count++;
}
if (count == 3)
return 0;
return 1;
}
void bfs(int sx, int sy)
{
q.push(sx);
q.push(sy);
cnt++;
int tx, ty;
arr[sx][sy] = 0;
while (!q.empty())
{
sx = q.front();
q.pop();
sy = q.front();
q.pop();
for (int k = 0; k < 4; k++)
{
tx = sx + s[k][0];
ty = sy + s[k][1];
if (tx >= 1 && tx <= m && ty >= 1 && ty <= n && arr[tx][ty] == 1)
{
arr[tx][ty] = 0;
q.push(tx);
q.push(ty);
}
}
}
}
int main()
{
cin >> m >> n;
for (int i = 1; i <= m; i++)
for (int j = 1; j <= n; j++)
{
arr[i][j] = 1;
}
for (int i = 1; i <= m; i++)
for (int j = 1; j <= n; j++){
cin >> ar[i][j];
if (ar[i][j] == '.')
arr[i][j] = 0;
}
for (int i = 1; i <= m; i++)
for (int j = 1; j <= n; j++)
{
if(i <= m && j <= n && fang(i, j) == 0)
{
cout << "Bad placement." << endl;
return 0;
}
}
for (int i = 1; i <= m; i++)
for (int j = 1; j <= n; j++)
{
if(arr[i][j] == 1)
bfs(i, j);
}
cout << "There are " << cnt << " ships." << endl;
return 0;
}
总结
1.Bad placement的思路来自于陈杉菜
2.海战代码具体思路和细胞数目思路基本一致,主要是加了对船不能并排停的思考
3.另外看到陈杉菜没有使用arr数组,直接判断 ” # “ 和 “ .”,确实更加简单