【BZOJ1014】[JSOI2008]火星人prefix
Description
火星人最近研究了一种操作:求一个字串两个后缀的公共前缀。比方说,有这样一个字符串:madamimadam,我们将这个字符串的各个字符予以标号:序号: 1 2 3 4 5 6 7 8 9 10 11 字符 m a d a m i m a d a m 现在,火星人定义了一个函数LCQ(x, y),表示:该字符串中第x个字符开始的字串,与该字符串中第y个字符开始的字串,两个字串的公共前缀的长度。比方说,LCQ(1, 7) = 5, LCQ(2, 10) = 1, LCQ(4, 7) = 0 在研究LCQ函数的过程中,火星人发现了这样的一个关联:如果把该字符串的所有后缀排好序,就可以很快地求出LCQ函数的值;同样,如果求出了LCQ函数的值,也可以很快地将该字符串的后缀排好序。 尽管火星人聪明地找到了求取LCQ函数的快速算法,但不甘心认输的地球人又给火星人出了个难题:在求取LCQ函数的同时,还可以改变字符串本身。具体地说,可以更改字符串中某一个字符的值,也可以在字符串中的某一个位置插入一个字符。地球人想考验一下,在如此复杂的问题中,火星人是否还能够做到很快地求取LCQ函数的值。
Input
第一行给出初始的字符串。第二行是一个非负整数M,表示操作的个数。接下来的M行,每行描述一个操作。操作有3种,如下所示
1、询问。语法:Qxy,x,y均为正整数。功能:计算LCQ(x,y)限制:1<=x,y<=当前字符串长度。
2、修改。语法:Rxd,x是正整数,d是字符。功能:将字符串中第x个数修改为字符d。限制:x不超过当前字符串长度。
3、插入:语法:Ixd,x是非负整数,d是字符。功能:在字符串第x个字符之后插入字符d,如果x=0,则在字符串开头插入。限制:x不超过当前字符串长度
Output
对于输入文件中每一个询问操作,你都应该输出对应的答案。一个答案一行。
Sample Input
7
Q 1 7
Q 4 8
Q 10 11
R 3 a
Q 1 7
I 10 a
Q 2 11
Sample Output
1
0
2
1
HINT
1、所有字符串自始至终都只有小写字母构成。
2、M<=150,000
3、字符串长度L自始至终都满足L<=100,000
4、询问操作的个数不超过10,000个。
对于第1,2个数据,字符串长度自始至终都不超过1,000
对于第3,4,5个数据,没有插入操作。
题解:用Splay维护节点的hash值,然后二分+hash求LCP即可。
本题貌似用很弱的hash方法也可以过。
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
typedef unsigned long long ull;
const int maxn=150010;
int n,m,tot,rt;
struct node
{
int ch[2],fa,siz;
ull v,hs;
}s[maxn];
char str[maxn];
ull bas[maxn];
void pushup(int x)
{
s[x].siz=s[s[x].ch[0]].siz+s[s[x].ch[1]].siz+1;
s[x].hs=(s[s[x].ch[0]].hs*131+s[x].v)*bas[s[s[x].ch[1]].siz]+s[s[x].ch[1]].hs;
}
void rotate(int x,int &k)
{
int y=s[x].fa,z=s[y].fa,d=(x==s[y].ch[1]);
if(y==k) k=x;
else s[z].ch[y==s[z].ch[1]]=x;
s[x].fa=z,s[y].fa=x,s[y].ch[d]=s[x].ch[d^1];
if(s[x].ch[d^1]) s[s[x].ch[d^1]].fa=y;
s[x].ch[d^1]=y;
pushup(y),pushup(x);
}
void splay(int x,int &k)
{
while(x!=k)
{
int y=s[x].fa,z=s[y].fa;
if(y!=k)
{
if((x==s[y].ch[0])^(y==s[z].ch[0])) rotate(x,k);
else rotate(y,k);
}
rotate(x,k);
}
}
int find(int x,int y)
{
if(!x) return 0;
if(y<=s[s[x].ch[0]].siz) return find(s[x].ch[0],y);
if(y==s[s[x].ch[0]].siz+1) return x;
return find(s[x].ch[1],y-s[s[x].ch[0]].siz-1);
}
void split(int a,int b)
{
splay(find(rt,a),rt),splay(find(rt,b+2),s[rt].ch[1]);
}
ull hash(int a,int b)
{
split(a,b);
return s[s[s[rt].ch[1]].ch[0]].hs;
}
int build(int l,int r,int last)
{
if(l>r) return 0;
int mid=l+r>>1;
s[mid].siz=r-l+1;
s[mid].fa=last;
s[mid].ch[0]=build(l,mid-1,mid),s[mid].ch[1]=build(mid+1,r,mid);
pushup(mid);
return mid;
}
int main()
{
int i,a,b,l,r,mid;
scanf("%s",str),n=strlen(str),tot=1;
for(bas[0]=1,i=1;i<=150000;i++) bas[i]=bas[i-1]*131;
for(i=0;i<n;i++) s[++tot].v=str[i];
tot++,rt=build(1,tot,0);
scanf("%d",&m);
for(i=1;i<=m;i++)
{
scanf("%s",str);
if(i==2706)
{
i++,i--;
}
if(str[0]=='Q')
{
scanf("%d%d",&a,&b);
l=1,r=min(tot-1-b,tot-1-a)+1;
while(l<r)
{
mid=l+r>>1;
if(hash(a,a+mid-1)==hash(b,b+mid-1)) l=mid+1;
else r=mid;
}
printf("%d\n",l-1);
}
else if(str[0]=='R')
{
scanf("%d%s",&a,str);
splay(find(rt,a+1),rt);
s[rt].v=str[0],pushup(rt);
}
else
{
scanf("%d%s",&a,str);
split(a+1,a);
s[++tot].v=str[0],s[tot].hs=s[tot].v,s[tot].siz=1,s[s[rt].ch[1]].ch[0]=tot,s[tot].fa=s[rt].ch[1];
pushup(s[rt].ch[1]),pushup(rt);
}
}
return 0;
}//madamimadam 7 Q 1 7 Q 4 8 Q 10 11 R 3 a Q 1 7 I 10 a Q 2 11