HDU 2147 kiki's game(规律,博弈)

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 10763    Accepted Submission(s): 6526

Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears
in his mind, she just playes the checkerboard game.The size of the
chesserboard is n*m.First of all, a coin is placed in the top right
corner(1,m). Each time one people can move the coin into the left, the
underneath or the left-underneath blank space.The person who can't make a
move will lose the game. kiki plays it with ZZ.The game always starts
with kiki. If both play perfectly, who will win the game?
 
Input
Input
contains multiple test cases. Each line contains two integer n, m
(0<n,m<=2000). The input is terminated when n=0 and m=0.
 
Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 
Sample Input
5 3
5 4
6 6
0 0
 
Sample Output
What a pity!
Wonderful!
Wonderful!
 
Author
月野兔
 
Source
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2147
分析:推几组数据就可以猜出结论,(a*b)%2==0?"Wonderful!":"What a pity!"
下面给出AC代码:
 #include <bits/stdc++.h>
using namespace std;
int main()
{
int a,b;
while(scanf("%d%d",&a,&b)&&(a&&b))
{
if(a*b%==)
printf("Wonderful!\n");
else printf("What a pity!\n");
}
return ;
}
上一篇:hdu2147 kiki's game(博弈)


下一篇:PHP结合Redis来限制用户或者IP某个时间段内访问的次数