hdoj 2147 kiki's game【博弈】

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 8041    Accepted Submission(s):
4781

Problem Description
Recently kiki has nothing to do. While she is bored, an
idea appears in his mind, she just playes the checkerboard game.The size of the
chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m).
Each time one people can move the coin into the left, the underneath or the
left-underneath blank space.The person who can't make a move will lose the game.
kiki plays it with ZZ.The game always starts with kiki. If both play perfectly,
who will win the game?
 
Input
Input contains multiple test cases. Each line contains
two integer n, m (0<n,m<=2000). The input is terminated when n=0 and
m=0.
 
Output
If kiki wins the game printf "Wonderful!", else "What a
pity!".
 
Sample Input
5 3
5 4
6 6
0 0
 
Sample Output
What a pity!
Wonderful!
Wonderful!
查找必胜点和必败点
1、只能通向必胜点的是必败点
#include<stdio.h>
#include<string.h>
int main()
{
int n,m,j,i;
while(scanf("%d%d",&n,&m)&&n!=0&&m!=0)
{
if(n*m&1)
printf("What a pity!\n");
else
printf("Wonderful!\n");
}
return 0;
}

  

上一篇:hdu 2147 kiki's game, 入门基础博弈


下一篇:hdu2147 kiki's game(博弈)