1055 The World‘s Richest (25 分)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤ 1 0 5 10^5 105) - the total number of people, and K (≤ 1 0 3 10^3 103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [ − 1 0 6 -10^6 −106, 1 0 6 10^6 106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50结尾无空行

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None结尾无空行

解释:

输入:

N,总的输入信息数,K,查询数

N行信息,包括 Name Age Net_Worth

K行查询,包括,前几,年龄范围

输出:

Case #查询到第几条:

信息 包括 Name Age Net_Worth

按财富降序,财富相同,年龄升序,年龄还相同,name升序

如果没有输出 None

#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;
typedef struct richer
{
    int age;
    string name;
    int wealth;
}Richer;

Richer r[100010];
bool cmp(Richer a, Richer b)
{
    if(a.wealth!=b.wealth)
        //财富降序
        return a.wealth>b.wealth;
    else
    {	//年龄升序
        if(a.age!=b.age) 
            return a.age<b.age;
        else //name升序
            return strcmp(a.name.data(),b.name.data())<0;
    }
}
int main()
{
    int N,M;
    cin>>N>>M;
    for(int i=0;i<N;i++)
        cin>>r[i].name>>r[i].age>>r[i].wealth;
    //排序
    sort(r,r+N,cmp);
    //查询
    for(int i=1;i<=M;i++)
    {
        int count=0;
        int number,min_age,max_age;
        //查询条件
        cin>>number>>min_age>>max_age;
        cout<<"Case #"<<i<<":"<<endl;
        //遍历数组
        for(int j=0;j<N;j++)
        {
            if(r[j].age>=min_age&&r[j].age<=max_age)
            {
               cout<<r[j].name<<" "<<r[j].age<<" "<<r[j].wealth<<endl;
               count++;
               if(count==number)
                   break;
            } 
        }
        //没查询到
        if(count==0) cout<<"None"<<endl;
    }
    return 0;
}

上一篇:Java语言的特点


下一篇:C#中equal与==的区别