ZOJ-3869,Ace of Aces(简单题)

Problem Description:

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input:

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

Output:

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.  

Sample Input: 

3

5

2 2 2 1 1

5 1 1 2 2 3

1

998 

Sample Output: 

2

Nobody

998 

AC Code: 

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define N 1001
int a[N],num[N];
int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(num,0,sizeof(num));//标记数组清零 
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			num[a[i]]++;//每个数出现一次就加1 
		}
		int max1=0,max2=0,x=0;
		for(int i=0;i<N;i++)
		{
			if(max1<num[i])//第一遍遍历数组,查找到出现次数最多的那个数 
			{
				max1=num[i];//赋值 
				x=i;//对应下标赋给x 
			}
		}
		for(int i=0;i<N;i++)//第二次遍历数组,是为了查重 
		{
			if(max2<num[i]&&i!=x)//两个下标不能相同 
			{
				max2=num[i];//赋值 
			}
		}
		if(max1==max2)//如果两个数出现次数相同 
			printf("Nobody\n");
		else
			printf("%d\n",x);
	}
	return 0;
}

 

ZOJ-3869,Ace of Aces(简单题)ZOJ-3869,Ace of Aces(简单题) Forever+Young 发布了302 篇原创文章 · 获赞 313 · 访问量 3万+ 私信 关注
上一篇:Day8 - G - Bound Found ZOJ - 1964


下一篇:Zoj 4063(构造题 思维题)