Help Hanzo(区间内素数个数)

Amakusa, the evil spiritual leader has captured the beautiful princess Nakururu. The reason behind this is he had a little problem with Hanzo Hattori, the best ninja and the love of Nakururu. After hearing the news Hanzo got extremely angry. But he is clever and smart, so, he kept himself cool and made a plan to face Amakusa.

Before reaching Amakusa’s castle, Hanzo has to pass some territories. The territories are numbered as a, a+1, a+2, a+3 … b. But not all the territories are safe for Hanzo because there can be other fighters waiting for him. Actually he is not afraid of them, but as he is facing Amakusa, he has to save his stamina as much as possible.

He calculated that the territories which are primes are safe for him. Now given a and b he needs to know how many territories are safe for him. But he is busy with other plans, so he hired you to solve this small problem!

Input
Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case contains a line containing two integers a and b (1 ≤ a ≤ b < 231, b - a ≤ 100000).

Output
For each case, print the case number and the number of safe territories.

Sample Input
3
2 36
3 73
3 11
Sample Output
Case 1: 11
Case 2: 20
Case 3: 4
Note
A number is said to be prime if it is divisible by exactly two different integers. So, first few primes are 2, 3, 5, 7, 11, 13, 17, …
题意
求区间[a,b]内的素数,标准模板题目。
解析
晚点写
代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define LL long long
bool prim[100010];
bool prims[100010];
void segment_sieve(LL a,LL b)
{
    for(int i=0; (LL)i*i<=b; i++) prims[i]=1;
    for(int i=0; i<=b-a; i++) prim[i]=1;
    for(int i=2; (LL)i*i<=b; i++)
    {
        if(prims[i])
        {
            for(int j=2*i; (LL)j*j<=b; j+=i)
            {
                prims[j]=0;
            }
            for(LL j=max(2LL,(a+i-1)/i)*i; j<=b; j+=i)
            {
                prim[j-a]=0;
            }
        }
    }
}
int main()
{
    LL a,b;
    int t,i,sum,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld",&a,&b);
        segment_sieve(a,b);
        sum=0;
        for(i=0; i<=b-a; i++)
        {
            if(prim[i])
                sum++;
        }
        if(a==1)sum--;  //特殊情况
        printf("Case %d: %d\n",cas++,sum);
    }
    return 0;
}
上一篇:linux下防止rm-rf /删除,让人崩溃


下一篇:SCP-juruo-002的档案