Accepted Necklace//HDU - 2660//dfs

Accepted Necklace//HDU - 2660//dfs


题目

I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won’t accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.
Input
The first line of input is the number of cases.
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.
Output
For each case, output the highest possible value of the necklace.
Sample Input
1
2 1
1 1
1 1
3
Sample Output
1
题意
串项链,重量之内价值尽可能高
链接:http://acm.hdu.edu.cn/showproblem.php?pid=2660

思路

dfs,重量作为判断条件即可

代码

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <string>

using namespace std;
pair<int,int> neck[30];
int n,t,k,W;
int maxn=0;
void dfs(int weight,int temp,int left,int price){
    if(weight>W||temp>=n) return;
    if(left==0){
        if(price>maxn) maxn=price;
        return ;
    }
    for(int i=temp;i<n;i++){
        dfs(weight+neck[i].second,i+1,left-1,price+neck[i].first);
    }
}
int main()
{
    cin>>t;
    for(int i=0;i<t;i++){
        cin>>n>>k;
        for(int j=0;j<n;j++){
            cin>>neck[j].first>>neck[j].second;
        }
        cin>>W;
        maxn=0;
        dfs(0,0,k,0);
        cout<<maxn<<endl;
    }
    return 0;
}

注意

Accepted Necklace//HDU - 2660//dfsAccepted Necklace//HDU - 2660//dfs salty_fishman 发布了14 篇原创文章 · 获赞 9 · 访问量 192 私信 关注
上一篇:POJ - 2379 ACM Rank Table


下一篇:JAVA RPC (十) nio服务端解析