PAT甲 1001. A+B Format (20) 2016-09-09 22:47 25人阅读 评论(0) 收藏

1001. A+B Format (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

很水的题,ab都比较小,直接算出答案,按位放到数组,注意3位移,  
#include<stdio.h>
int main()
{
int a,b,c,i,s[1000],j,k,x,n,y;
while(scanf("%d%d",&a,&b)!=EOF)
{
c=a+b;
k=c;
i=0;
if(c==0)
printf("0\n");
else
{
while(c!=0)
{
s[i]=c%10;
c=c/10;
i++;
j=i;
} if(k<0)
{
printf("-");
for(i=0;i<j;i++)
s[i]=-s[i];
}
x=j%3;
y=x;
for(i=j-1;i>j-x-1;i--)
printf("%d",s[i]);
n=0;
for(i=j-x-1;i>=0;i--)
{
if(n++%3==0&&y++!=0)
printf(",");
printf("%d",s[i]);
}
printf("\n");
}
}
return 0;
}

上一篇:1001.A+B Format (20)代码自查(补足版)


下一篇:1001. A+B Format (20) (%0nd)