POJ 2739 Sum of Consecutive Prime Numbers(尺取法)

题目链接: 传送门

Sum of Consecutive Prime Numbers

Time Limit: 1000MS     Memory Limit: 65536K

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

解题思路

题目大意:问有几种方式,把一个数分成几个连续的素数的和。
跑一遍埃氏筛选法,筛选出素数,然后尺取法的思路不断推进。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 10005;
int prime[MAX];
bool is_prime[MAX];

int main()
{
    int p = 0;
    memset(is_prime,true,sizeof(is_prime));
    is_prime[0] = is_prime[1] = false;
    for (int i = 2;i <= MAX;i++)
    {
        if (is_prime[i])
        {
            prime[p++] = i;
            for (int j = 2*i;j <= MAX;j += i)
            {
                is_prime[j] = false;
            }
        }
    }
    int N;
    while (~scanf("%d",&N) && N)
    {
        bool flag = false;
        int cnt = 0,s = 0,t = 0,sum = 0;
        for (;;)
        {
            if (prime[t] >= N)  break;
            while (sum < N)
            {
                sum += prime[t++];
                if (sum == N)
                {
                    flag = true;
                }
            }
            if (flag)
            {
                cnt++;
                flag = false;
            }
            sum -= prime[s++];
            if (sum == N && prime[t] < N)
            {
                cnt++;
                sum -= prime[s++];
            }
        }
        if (is_prime[N])printf("%d\n",cnt+1);
        else if (cnt)printf("%d\n",cnt);
        else printf("0\n");
    }
    return 0;
}
上一篇:表达式:使用API创建表达式树(5)


下一篇:POJ.2739 Sum of Consecutive Prime Numbers(水)