iOS 7 Pushing the Limits - Good & Bad Namings in Cocoa

Cocoa is a dynamically typed language, and you can easily get confused about what type you are working with.
Collections (arrays, dictionaries, and so on) don’t have types associated with them, so it’s very easy to code
something accidentally like this:


NSArray *dates = @[@”1/1/2000”];
NSDate *firstDate = [dates firstObject];

 

This code compiles without a warning, but will crash with an unknown
selector exception.

 

Let‘s look at following code lines:

- (void)setURL:(NSString *)URL;              // Bad

- (void)setURLString:(NSString *)string;  // Good
- (void)setURL:(NSURL *)URL;                // Good

 

category methods

Because of the possibility of collisions, you should add a prefix to your category methods

Cocoa generally doesn’t use embedded underscores

A good use of categories is to provide utility methods to existing classes. When you do this, I recommend
naming the header and implementation files using the name of the original class plus the name of the
extension.

For example, you might create a simple PTLExtensions category on NSDate:

NSDate+PTLExtensions.h

@interface NSDate (PTLExtensions)
- (NSTimeInterval)ptl_timeIntervalUntilNow;
@end

NSDate+PTLExtensions.m

@implementation NSDate (PTLExtensions)
- (NSTimeInterval)ptl_timeIntervalUntilNow {
  return -[self timeIntervalSinceNow];
}
@end

 

iOS 7 Pushing the Limits - Good & Bad Namings in Cocoa,布布扣,bubuko.com

iOS 7 Pushing the Limits - Good & Bad Namings in Cocoa

上一篇:设置app的语言


下一篇:【iOS开发必收藏】详解iOS应用程序内使用IAP/StoreKit付费、沙盒(SandBox)测试、创建测试账号流程!【2012-12-11日更新获取”产品付费数量等于0的问题”】