A1048 Find Coins (寻找硬币)
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤105, the total number of coins) and M (≤103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1+V2=M and V1≤V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output No Solution
instead.
Sample Input 1:
8 15
1 2 8 7 2 4 11 15结尾无空行
Sample Output 1:
4 11
结尾无空行
Sample Input 2:
7 14
1 8 7 2 4 11 15结尾无空行
Sample Output 2:
No Solution
结尾无空行
分析:
这道题目也不难,就是要注意当钱的数值是一样的时候,要看看是否有两个值
代码如下:
#include<cstdio>
#include<algorithm>
using namespace std;
bool HashTable[100010]={false};
int num[100010]={0};
int main(){
int m,n,v1,v2,i;
bool flag=false;
int coin[100010];
scanf("%d %d",&m,&n);
for(int i=0;i<m;i++){
scanf("%d",&coin[i]);
num[coin[i]]++;
HashTable[coin[i]]=true;
}
sort(coin,coin+m);
int min=100;
for(i=0;i<m;i++){
if(HashTable[n-coin[i]]){//可以输出
if(coin[i]==(n-coin[i])){
if(num[coin[i]]!=1){
flag=true;
break;
}
}else{
flag=true;
break;
}
}
}
if(flag) printf("%d %d",coin[i],n-coin[i]);
else printf("No Solution");
return 0;
}