hdu4931 Happy Three Friends(BestCoder Round#4签到题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4931


Happy Three Friends

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 150    Accepted Submission(s): 128


Problem Description
Dong-hao , Grandpa Shawn , Beautful-leg Mzry are good friends. One day , they want to play a game.

There are 6 numbers on the table.

Firstly , Dong-hao can change the order of 6 numbers.

Secondly , Grandpa Shawn take the first one and the last one , sum them up as his scores.

Thirdly , Beautiful-leg Mzry take any of 3 numbers from the last 4 numbers , and sum them up as his scores.

Finally , if Grandpa Shawn‘s score is larger than Beautiful-leg Mzry‘s , Granpa Shawn wins!

If Grandpa Shawn‘s score is smaller than Beautiful-leg Mzry‘s , Granpa Shawn loses.

If the scores are equal , there is a tie.

Nowadays , it‘s really sad that Grandpa Shawn loses his love. So Dong-hao wants him to win(not even tie). You have to tell Dong-hao whether he can achieve his goal.
 
Input
There is a number T shows there are T test cases below. ( T <= 50)

For each test case , there are 6 numbers Ai ( 1 <= Ai <= 100 ).
 
Output
If Dong-hao can achieve his goal , output "Grandpa Shawn is the Winner!"
If he can not , output "What a sad story!"
 
Sample Input
3 1 2 3 3 2 2 2 2 2 2 2 2 1 2 2 2 3 4
 
Sample Output
What a sad story! What a sad story! Grandpa Shawn is the Winner!
Hint
For the first test case , {3 , 1 , 2 , 2 , 2 , 3} Grandpa Shawn can take 6 at most . But Beautiful-leg Mzry can take 6 too. So there is a tie. For the second test cases , Grandpa Shawn loses. For the last one , Dong-hao can arrange the numbers as {3 , 2 , 2 , 2 , 1 , 4} , Grandpa Shawn can take 7 , but Beautiful-leg Mzry can take 6 at most. So Grandpa Shawn Wins!
 
Source

代码如下:

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
     int t;
     int a[6];
     while(~scanf("%d",&t))
     {
          while(t--)
          {
               for(int i = 0; i < 6; i++)
               {
                    scanf("%d",&a[i]);
               }
               sort(a,a+6);
               if(a[5]+a[4] > a[3]+a[2]+a[1])
               {
                    printf("Grandpa Shawn is the Winner!\n");
               }
               else
                    printf("What a sad story!\n");
          }
     }
     return 0;
}


hdu4931 Happy Three Friends(BestCoder Round#4签到题),布布扣,bubuko.com

hdu4931 Happy Three Friends(BestCoder Round#4签到题)

上一篇:Android单元测试,使用ThreadingTest进行全新体验


下一篇:iOS UIAlertView中UIActivityindicatorView风火轮提示加载等待