hdu 4925 Apple Tree

Apple Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 244    Accepted Submission(s): 173


Problem Description
I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map. In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’ production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x + 1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?
 

Input
The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.
For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.
 

Output
For each test case, you should output the maximum number of apples I can obtain.
 

Sample Input
2 2 2 3 3
 

Sample Output
8 32
 

Author
BUPT
 

Source

比赛时看了一下样例,想找规律,突然就觉得隔一个格子放一个能得到最大值,根据横纵坐标和的奇偶性分别染色

枚举两种情况求最大值。。


#include"stdio.h"
#include"string.h"
#include"queue"
#include"vector"
using namespace std;
#define N 105
#define M 1000000
int g[N][N];
int n,m;
int dir[4][2]={0,1,0,-1,-1,0,1,0};
int judge(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m)
        return 1;
    return 0;
}
int main()
{
    int T,i,j;
    int k,x,y;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(g,0,sizeof(g));
        __int64 ans=0,max;
        ans=max=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if((i+j)%2)          //奇数的种苹果树
                    g[i][j]=1;
            }
        }
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(g[i][j]==0)
                    continue;
                for(k=0;k<4;k++)
                {
                    x=i+dir[k][0];
                    y=j+dir[k][1];
                    if(judge(x,y)&&g[x][y]==0)
                    {
                        g[i][j]*=2;
                    }
                }
                ans+=g[i][j];
            }
        }
        max=ans;
        ans=0;

        memset(g,0,sizeof(g));
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if((i+j)%2==0)     //偶数的种苹果树
                    g[i][j]=1;
            }
        }
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(g[i][j]==0)
                    continue;
                for(k=0;k<4;k++)
                {
                    x=i+dir[k][0];
                    y=j+dir[k][1];
                    if(judge(x,y)&&g[x][y]==0)
                    {
                        g[i][j]*=2;
                    }
                }
                ans+=g[i][j];
            }
        }
        max=max>ans?max:ans;
        printf("%I64d\n",max);
    }
    return 0;
}





hdu 4925 Apple Tree,布布扣,bubuko.com

hdu 4925 Apple Tree

上一篇:android 4.0之前版本出现JSONException异常


下一篇:JS与FLEX|AS实现互相调用