HihoCoder - 1828 Saving Tang Monk II(bfs+优先队列)

《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng’en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace, and he wanted to reach Tang Monk and rescue him.

The palace can be described as a matrix of characters. Different characters stand for different rooms as below:

‘S’ : The original position of Sun Wukong

‘T’ : The location of Tang Monk

‘.’ : An empty room

‘#’ : A deadly gas room.

‘B’ : A room with unlimited number of oxygen bottles. Every time Sun Wukong entered a ‘B’ room from other rooms, he would get an oxygen bottle. But staying there would not get Sun Wukong more oxygen bottles. Sun Wukong could carry at most 5 oxygen bottles at the same time.

‘P’ : A room with unlimited number of speed-up pills. Every time Sun Wukong entered a ‘P’ room from other rooms, he would get a speed-up pill. But staying there would not get Sun Wukong more speed-up pills. Sun Wukong could bring unlimited number of speed-up pills with him.

Sun Wukong could move in the palace. For each move, Sun Wukong might go to the adjacent rooms in 4 directions(north, west,south and east). But Sun Wukong couldn’t get into a ‘#’ room(deadly gas room) without an oxygen bottle. Entering a ‘#’ room each time would cost Sun Wukong one oxygen bottle.

Each move took Sun Wukong one minute. But if Sun Wukong ate a speed-up pill, he could make next move without spending any time. In other words, each speed-up pill could save Sun Wukong one minute. And if Sun Wukong went into a ‘#’ room, he had to stay there for one extra minute to recover his health.

Since Sun Wukong was an impatient monkey, he wanted to save Tang Monk as soon as possible. Please figure out the minimum time Sun Wukong needed to reach Tang Monk.

Input
There are no more than 25 test cases.

For each case, the first line includes two integers N and M(0 < N,M ≤ 100), meaning that the palace is a N × M matrix.

Then the N×M matrix follows.

The input ends with N = 0 and M = 0.

Output
For each test case, print the minimum time (in minute) Sun Wukong needed to save Tang Monk. If it’s impossible for Sun Wukong to complete the mission, print -1

Sample Input
2 2
S#
#T
2 5
SB###
##P#T
4 7
SP…
P#…
…#
B…##T
0 0
Sample Output
-1
8
11

思路:搜索,100*100的图,dfs超时,要用bfs,注意记录状态的时候要记录三维(卡死在这里),因为这个图,为‘B’的点有时候需要走多次,但是每一个最多五次,所以再加一维状态,记录当前氧气数量。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
	int x,y,b,p,t;
	friend bool operator < (const node m,const node n)
	{
		return m.t>n.t;
	}
};
int vis[105][105][10];
int n,m,sx,sy,tx,ty;
char a[105][105];
int nex[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int bfs()
{
	priority_queue<node> q;
	q.push({sx,sy,0,0,0});
	vis[sx][sy][0]=1;
	while(q.size())
	{
		node tem=q.top();q.pop();
		int x=tem.x,y=tem.y,t=tem.t,b=tem.b,p=tem.p;
		//cout<<x<<" "<<y<<" "<<b<<" "<<p<<" "<<t<<endl;
		if(x==tx&&y==ty)
			return t;
		for(int i=0;i<4;i++)
		{
			int xx=x+nex[i][0],yy=y+nex[i][1],tt=t,bb=b,pp=p;
			if(xx<0||xx>=n||yy<0||yy>=m||(a[xx][yy]=='#'&&!b))
				continue;
			tt++;
			if(a[xx][yy]=='#')
				bb--,tt++;
			if(a[xx][yy]=='B')
				bb=min(5,bb+1);
			if(a[xx][yy]=='P')
				tt--;
			if(!vis[xx][yy][bb])
			{
				vis[xx][yy][bb]=1;q.push({xx,yy,bb,pp,tt});
			}
		} 
	}
	return -1;
}
int main()
{
	while(~scanf("%d%d",&n,&m)&&n+m)
	{
		memset(vis,0,sizeof vis);
		for(int i=0;i<n;i++)
		{
			scanf("%s",a[i]);
			for(int j=0;j<m;j++)
			{
				if(a[i][j]=='S')
					sx=i,sy=j;
				if(a[i][j]=='T')
					tx=i,ty=j;
			}
		}
		cout<<bfs()<<endl;
	}
	return 0;
}
上一篇:有参跟无参


下一篇:android – 让zxing以纵向模式运行