POJ - 1276 Cash Machine

Cash Machine

POJ - 1276

AYIT-2021 609暑假集训第一周下 记忆化搜索和背包

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

题意:各种面额的钱是有张数限制,求最大能凑出的面额(小于等于目标面额的最大值)
题型:多重背包,二进制优化

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int v[100010],dp[100010];
int main()
{
	int i,j,n,m,a,b,nn;
	while(~scanf("%d%d",&m,&n))
	{
		memset(dp,0,sizeof(dp));
		for(nn=i=0;i<n;i++)//二进制优化(二进制拆分)
        {
            scanf("%d%d",&a,&b);
            for(int j=1;j<=a;j*=2)
            {
                v[nn++]=j*b;
                a-=j;
            }
            if(a>0)
                v[nn++]=a*b;
        }
		for(i=0;i<nn;i++)
			for(j=m;j>=v[i];j--)
				dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
		printf("%d\n",dp[m]);
	}
	return 0;
}
上一篇:A1016 Phone Bills


下一篇:翻译:《实用的Python编程》01_02_Hello_world