HDU 1051 Wooden Sticks (贪心)

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14126    Accepted Submission(s): 5842

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 



(a) The setup time for the first wooden stick is 1 minute. 

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 



You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case,
and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 
Output
The output should contain the minimum setup time in minutes, one per line.
 
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
 
Sample Output
2
1
3
 

#include <stdio.h>
#include <algorithm>
using namespace std;
//1051
typedef struct node
{
int x,y,isUsed;
}NODE; int cmp(NODE a, NODE b)
{
//假设x同样。就按y降序排序
if (a.x == b.x)
{
return a.y>b.y;
}
else
{
return a.x>b.x;
}
} int main()
{
int T,N;
NODE c[5001];
while (scanf("%d", &T)!=EOF)
{
while (T--)
{
scanf("%d", &N);
for (int i=0; i<N; i++)
{
scanf("%d %d", &c[i].x, &c[i].y);
c[i].isUsed = 0;
}
sort(c, c+N, cmp); int time = 0;
for (int i=0; i<N; i++)
{
if (c[i].isUsed == 1)
continue;
int x,y;
x = c[i].x; y = c[i].y;
//标记当前为用过了
c[i].isUsed = 1;
for (int j=i+1; j<N; j++)
{
if (c[j].x<=x && c[j].y<=y && c[j].isUsed == 0)
{
x = c[j].x;
y = c[j].y;
c[j].isUsed = 1;
}
}
time++;
}
printf("%d\n", time);
}
} return 0;
}
上一篇:git个人学习总结


下一篇:定时任务框架APScheduler