HDU 1051 Wooden Sticks 贪心||DP

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22000    Accepted Submission(s): 8851

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 
Output
The output should contain the minimum setup time in minutes, one per line.
 
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
 
Sample Output
2
1
3
 
Source
思路:将木棒按l,w 递减的顺序排列,统计关于递减的连续子列的个数即为答案。
代码:
 #include "cstdio"
 #include "iostream"
 #include "algorithm"
 #include "string"
 #include "cstring"
 #include "queue"
 #include "cmath"
 #include "vector"
 #include "map"
 #include "stdlib.h"
 #include "set"
 #define mj
 #define db double
 #define ll long long
 using  namespace std;
 ;
 ;
 ;
 bool u[N];
 typedef  struct stu{
     int l,w;
 }M;
 M s[];
 int cmp(M a,M b)
 {
     if(a.l==b.l) return a.w>=b.w;
     return a.l>=b.l;
 }
 int main()
 {
     int t,n,i,j,ans;
     scanf("%d",&t);
     while(t--)
     {
         scanf("%d",&n);
         ;i<n;i++)
             scanf(;
         sort(s,s+n,cmp);
         int mi;
         ans=;
         ;i<n;i++)
         {
             if(u[i]) continue;
             mi=s[i].w;
             ;j<n;j++)
             {
                 if(!u[j]&&s[j].w<=mi){
                     mi=s[j].w;
                     u[j]=;
                 }
             }
             ans++;
         }
         printf("%d\n",ans);
     }
     ;
 }
 
上一篇:POJ2777


下一篇:Web中路径问题