一、BGP属性分类
公有必遵 |
Origin(起源属性) |
IGP(i)、EGP(e)、Incomplete(?) |
AS-PATH(路径属性) |
越短越优(EBGP、IBGP) |
|
Next-Hop(下一跳属性) |
/ |
|
公认任意 |
Local Pref(本地优先级属性) |
越大越优(IBGP) |
可选过渡 |
Community(社区属性) |
/ |
可选非过渡 |
MED属性 |
MED值越小越优(EBGP、IBGP) |
二、BGP选路规则
1、若去往目的网络的路由下一跳不可达,则可以忽略此路由
2、Preferred-Value优先级以数值高的路由优先
3、Local-Preference优先级以数值高的路由优先(默认100)
4、聚合路由优先级高于非聚合路由
5、本地手动聚合路由的优先级高于本地自动聚合的路由
6、本地通过Network命令引入的路由的优先级高于本地通过Import-route命令引入的路由
7、AS路径长度最短(最少个数)的路径优先级高
8、比较Origin属性,IGP优先级高于EGP,EGP优先级高于Incomplete
9、选择MED优先级较小的路由
10、EBGP路由优先级高于IBGP路由
11、BGP优先选择到BGP下一跳的IGP度量低的路经
当以上全部相同,则为等价路由,可以负载分担(注:AS-PATH必须一致),当负载分担时,以下3条原则无线
12、比较Cluster-List长度,短者优先
13、比较Originator ID(如果没有Originator ID,则用Router ID比较)选择数值较小的路径
14、比较对等体的IP地址,选择IP地址数值最小的路径
三、BGP属性配置
要求:R1环回到R5 环回从R2走
R5环回到R1 环回从R3走
R1配置信息:
<Huawei>undo terminal monitor
<Huawei>system-view
[Huawei]user-interface console 0
[Huawei-ui-console0]idle-timeout 0 0
[Huawei-ui-console0]sysname R1
[R1]int g0/0/0
[R1-GigabitEthernet0/0/0]ip add 12.1.1.1 24
[R1-GigabitEthernet0/0/0]undo shutdown
[R1-GigabitEthernet0/0/0]int g0/0/1
[R1-GigabitEthernet0/0/1]ip add 13.1.1.1 24
[R1-GigabitEthernet0/0/1]undo shutdown
[R1-GigabitEthernet0/0/1]int loop 0
[R1-LoopBack0]ip add 1.1.1.1 32
[R1-LoopBack0]quit
[R1]ip route-static 2.2.2.2 32 12.1.1.2
[R1]ip route-static 3.3.3.3 32 13.1.1.2
[R1]bgp 300
[R1-bgp]router-id 1.1.1.1
[R1-bgp]peer 2.2.2.2 as-number 200
[R1-bgp]peer 2.2.2.2 connect-interface loop 0
[R1-bgp]peer 2.2.2.2 ebgp-max-hop 255
[R1-bgp]peer 3.3.3.3 as-number 200
[R1-bgp]peer 3.3.3.3 connect-interface loop 0
[R1-bgp]peer 3.3.3.3 ebgp-max-hop 255
[R1-bgp]network 1.1.1.1 32
[R1-bgp]network 12.1.1.0 24
[R1-bgp]network 13.1.1.0 24
R2配置信息:
<Huawei>undo terminal monitor
<Huawei>system-view
[Huawei]user-interface console 0
[Huawei-ui-console0]idle-timeout 0 0
[Huawei-ui-console0]sysname R2
[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]ip add 12.1.1.2 24
[R2-GigabitEthernet0/0/0]undo shutdown
[R2-GigabitEthernet0/0/0]int g0/0/1
[R2-GigabitEthernet0/0/1]ip add 23.1.1.2 24
[R2-GigabitEthernet0/0/1]undo shutdown
[R2-GigabitEthernet0/0/1]int loop 0
[R2-LoopBack0]ip add 2.2.2.2 32
[R2-LoopBack0]quit
[R2]ospf 1 router-id 2.2.2.2
[R2-ospf-1]area 0
[R2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
[R2-ospf-1-area-0.0.0.0]network 23.1.1.0 0.0.0.255
[R2-ospf-1-area-0.0.0.0]quit
[R2-ospf-1]quit
[R2]ip route-static 1.1.1.1 32 12.1.1.1
[R2]bgp 200
[R2-bgp]router-id 2.2.2.2
[R2-bgp]peer 1.1.1.1 as-number 100
[R2-bgp]peer 1.1.1.1 connect-interface loop 0
[R2-bgp]peer 1.1.1.1 ebgp-max-hop 255
[R2-bgp]peer 3.3.3.3 as-number 200
[R2-bgp]peer 3.3.3.3 connect-interface loop 0
[R2-bgp]peer 3.3.3.3 next-hop-local
[R2-bgp]peer 4.4.4.4 as-number 200
[R2-bgp]peer 4.4.4.4 connect-interface loop 0
[R2-bgp]peer 4.4.4.4 next-hop-local
[R2-bgp]network 1.1.1.1 32
[R2-bgp]network 2.2.2.2 32
[R2-bgp]network 3.3.3.3 32
[R2-bgp]network 4.4.4.4 32
[R2-bgp]network 12.1.1.0 24
[R2-bgp]network 23.1.1.0 24
[R2-bgp]quit
R3配置信息:
<Huawei>undo terminal monitor
<Huawei>system-view
[Huawei]user-interface console 0
[Huawei-ui-console0]idle-timeout 0 0
[Huawei-ui-console0]sysname R3
[R3]int g0/0/0
[R3-GigabitEthernet0/0/0]ip add 13.1.1.3 24
[R3-GigabitEthernet0/0/0]undo shutdown
[R3-GigabitEthernet0/0/0]int g0/0/1
[R3-GigabitEthernet0/0/1]ip add 34.1.1.3 24
[R3-GigabitEthernet0/0/1]undo shutdown
[R3-GigabitEthernet0/0/1]int loop 0
[R3-LoopBack0]ip add 3.3.3.3 32
[R3-LoopBack0]quit
[R3]ospf 1 router-id 3.3.3.3
[R3-ospf-1]area 0
[R3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
[R3-ospf-1-area-0.0.0.0]network 34.1.1.0 0.0.0.255
[R3-ospf-1-area-0.0.0.0]quit
[R3-ospf-1]quit
[R3]ip route-static 1.1.1.1 32 13.1.1.1
[R3]bgp 200
[R3-bgp]peer 1.1.1.1 as-number 100
[R3-bgp]peer 1.1.1.1 connect-interface loop 0
[R3-bgp]peer 1.1.1.1 ebgp-max-hop 255
[R3-bgp]peer 2.2.2.2 as-number 200
[R3-bgp]peer 2.2.2.2 connect-interface loop 0
[R3-bgp]peer 2.2.2.2 next-hop-local
[R3-bgp]peer 4.4.4.4 as-number 200
[R3-bgp]peer 4.4.4.4 connect-interface loop 0
[R3-bgp]peer 4.4.4.4 next-hop-local
[R3-bgp]network 1.1.1.1 32
[R3-bgp]network 2.2.2.2 32
[R3-bgp]network 3.3.3.3 32
[R3-bgp]network 4.4.4.4 32
[R3-bgp]network 13.1.1.0 24
[R3-bgp]network 34.1.1.0 24
[R3]acl 2000
[R3-acl-basic-2000]rule permit source 5.5.5.5 0.0.0.0
[R3-acl-basic-2000]quit
[R3]route-policy as permit node 10
[R3-route-policy]if-match acl 2000
[R3-route-policy]apply as-path 222 333 444 additive
[R3-route-policy]quit
[R3]route-policy as permit node 20
[R3-route-policy]quit
[R3]bgp 200
[R3-bgp]peer 1.1.1.1 route-policy as export
[R3-bgp]quit
[R3]quit
<R3>reset bgp all
<R3>system-view
[R3]acl 2001
[R3-acl-basic-2001]rule permit source 1.1.1.1 0.0.0.0
[R3-acl-basic-2001]quit
[R3]route-policy local permit node 10
[R3-route-policy]if-match acl 2001
[R3-route-policy]apply local-preference 200
[R3-route-policy]quit
[R3]route-policy local permit node 20
[R3-route-policy]quit
[R3]bgp 200
[R3-bgp]peer 4.4.4.4 route-policy local export
[R3-bgp]quit
[R3]quit
<R3>reset bgp all
R4配置信息:
<Huawei>undo terminal monitor
<Huawei>system-view
[Huawei]user-interface console 0
[Huawei-ui-console0]idle-timeout 0 0
[Huawei-ui-console0]sysname R4
[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]ip add 23.1.1.4 24
[R4-GigabitEthernet0/0/0]undo shutdown
[R4-GigabitEthernet0/0/0]int g0/0/1
[R4-GigabitEthernet0/0/1]ip add 34.1.1.4 24
[R4-GigabitEthernet0/0/1]undo shutdown
[R4-GigabitEthernet0/0/1]int g0/0/2
[R4-GigabitEthernet0/0/2]ip add 45.1.1.4 24
[R4-GigabitEthernet0/0/2]undo shutdown
[R4-GigabitEthernet0/0/1]int loop 0
[R4-LoopBack0]ip add 4.4.4.4 32
[R4-LoopBack0]quit
[R4]ospf 1 router-id 4.4.4.4
[R4-ospf-1]area 0
[R4-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0
[R4-ospf-1-area-0.0.0.0]network 23.1.1.0 0.0.0.255
[R4-ospf-1-area-0.0.0.0]network 34.1.1.0 0.0.0.255
[R4-ospf-1-area-0.0.0.0]quit
[R4-ospf-1]quit
[R4]ip route-static 1.1.1.1 32 13.1.1.1
[R4]bgp 200
[R4-bgp]router-id 4.4.4.4
[R4-bgp]peer 2.2.2.2 as-number 200
[R4-bgp]peer 2.2.2.2 connect-interface loop 0
[R4-bgp]peer 2.2.2.2 next-hop-local
[R4-bgp]peer 3.3.3.3 as-number 200
[R4-bgp]peer 3.3.3.3 connect-interface loop 0
[R4-bgp]peer 3.3.3.3 next-hop-local
[R4-bgp]peer 5.5.5.5 as-number 300
[R4-bgp]peer 5.5.5.5 connect-interface loop 0
[R4-bgp]peer 5.5.5.5 ebgp-max-hop 255
[R4-bgp]quit
[R4]ip route-static 5.5.5.5 32 45.1.1.5
[R4]bgp 200
[R4-bgp]network 2.2.2.2 32
[R4-bgp]network 3.3.3.3 32
[R4-bgp]network 4.4.4.4 32
[R4-bgp]network 5.5.5.5 32
[R4-bgp]network 34.1.1.0 24
[R4-bgp]network 23.1.1.0 24
[R4-bgp]network 45.1.1.0 24
R5配置信息:
<Huawei>undo terminal monitor
<Huawei>system-view
[Huawei]user-interface console 0
[Huawei-ui-console0]idle-timeout 0 0
[Huawei-ui-console0]sysname R5
[R5]int g0/0/0
[R5-GigabitEthernet0/0/0]ip add 45.1.1.5 24
[R5-GigabitEthernet0/0/0]undo shutdown
[R5-GigabitEthernet0/0/0]int loop 0
[R5-LoopBack0]ip add 5.5.5.5 32
[R5-LoopBack0]quit
[R5]ip route-static 4.4.4.4 32 45.1.1.4
[R5]bgp 300
[R5-bgp]router-id 5.5.5.5
[R5-bgp]peer 4.4.4.4 as-number 200
[R5-bgp]peer 4.4.4.4 connect-interface loop 0
[R5-bgp]peer 4.4.4.4 ebgp-max-hop 255
[R5-bgp]network 5.5.5.5 32
[R5-bgp]network 45.1.1.0 24