UVa348 - Optimal Array Multiplication Sequence

Optimal Array Multiplication Sequence 

Given two arrays A and B, we can determine the array C = A B using the standard definition of matrix multiplication:

UVa348 - Optimal Array Multiplication Sequence

The number of columns in the A array must be the same as the number of rows in the B array. Notationally, let‘s say that rows(A) and columns(A) are the number of rows and columns, respectively, in the A array. The number of individual multiplications required to compute the entire C array (which will have the same number of rows as A and the same number of columns as B) is then rows(Acolumns(Bcolumns(A). For example, if Ais a UVa348 - Optimal Array Multiplication Sequence array, and B is a UVa348 - Optimal Array Multiplication Sequence array, it will take UVa348 - Optimal Array Multiplication Sequence , or 3000 multiplications to compute the C array.

To perform multiplication of more than two arrays we have a choice of how to proceed. For example, if XY, and Z are arrays, then to compute X Y Z we could either compute (X YZ or X (Y Z). Suppose X is a UVa348 - Optimal Array Multiplication Sequencearray, Y is a UVa348 - Optimal Array Multiplication Sequence array, and Z is a UVa348 - Optimal Array Multiplication Sequence array. Let‘s look at the number of multiplications required to compute the product using the two different sequences:

(X YZ

  • UVa348 - Optimal Array Multiplication Sequence multiplications to determine the product (X Y), a UVa348 - Optimal Array Multiplication Sequence array.
  • Then UVa348 - Optimal Array Multiplication Sequence multiplications to determine the final result.
  • Total multiplications: 4500.

X (Y Z)

  • UVa348 - Optimal Array Multiplication Sequence multiplications to determine the product (Y Z), a UVa348 - Optimal Array Multiplication Sequence array.
  • Then UVa348 - Optimal Array Multiplication Sequence multiplications to determine the final result.
  • Total multiplications: 8750.

Clearly we‘ll be able to compute (X YZ using fewer individual multiplications.

Given the size of each array in a sequence of arrays to be multiplied, you are to determine an optimal computational sequence. Optimality, for this problem, is relative to the number of individual multiplications required.

Input

For each array in the multiple sequences of arrays to be multiplied you will be given only the dimensions of the array. Each sequence will consist of an integer N which indicates the number of arrays to be multiplied, and then N pairs of integers, each pair giving the number of rows and columns in an array; the order in which the dimensions are given is the same as the order in which the arrays are to be multiplied. A value of zero for N indicates the end of the input. N will be no larger than 10.

Output

Assume the arrays are named UVa348 - Optimal Array Multiplication Sequence . Your output for each input case is to be a line containing a parenthesized expression clearly indicating the order in which the arrays are to be multiplied. Prefix the output for each case with the case number (they are sequentially numbered, starting with 1). Your output should strongly resemble that shown in the samples shown below. If, by chance, there are multiple correct sequences, any of these will be accepted as a valid answer.

Sample Input

3
1 5
5 20
20 1
3
5 10
10 20
20 35
6
30 35
35 15
15 5
5 10
10 20
20 25
0

Sample Output

Case 1: (A1 x (A2 x A3))
Case 2: ((A1 x A2) x A3)
Case 3: ((A1 x (A2 x A3)) x ((A4 x A5) x A6))


一道要求输出方案的区间DP题,用记忆化DP可以很好地分析清楚状态
for(int i = st; i <= ed-1; i++)  ans = min(ans,dfs(st,i)+dfs(i+1,ed)+vn[st].x*vn[i].y*vn[ed].y);
输出方案的时候主要递归输出即可
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
#include <sstream>
using namespace std;
const int INF = 1e9;
int n;
struct node{
    int x,y;
    string name;
};
vector<node> vn;
int dp[20][20];
void init(){
    vn.clear();
    vn.resize(n);
    memset(dp,-1,sizeof dp);
}
void input(){
    for(int i = 0; i < n; i++){
        stringstream ss;
        ss<<i+1;
        vn[i].name = "A"+ss.str();
        scanf("%d%d",&vn[i].x,&vn[i].y);
    }
}
int dfs(int st,int ed){
    if(st==ed) return 0;
    if(dp[st][ed]!=-1) return dp[st][ed];
    int ans = INF;
    for(int i = st; i <= ed-1; i++)  ans = min(ans,dfs(st,i)+dfs(i+1,ed)+vn[st].x*vn[i].y*vn[ed].y);
    return dp[st][ed] = ans;
}
void getsol(int st,int ed){
    if(st==ed){
        cout<<vn[st].name;
        return;
    }
    int k = st;
    int ans = INF;
    for(int i = st; i <= ed-1; i++)
        if(ans>dfs(st,i)+dfs(i+1,ed)+vn[st].x*vn[i].y*vn[ed].y){
            ans = dfs(st,i)+dfs(i+1,ed)+vn[st].x*vn[i].y*vn[ed].y;
            k = i;
        }
    if(st!=k) printf("(");
    getsol(st,k);
    if(st!=k) printf(")");
    printf(" x ");
    if(ed!=k+1)printf("(");
    getsol(k+1,ed);
    if(ed!=k+1)printf(")");
}
void solve(){
    int ans = dfs(0,n-1);
    printf("(");
    getsol(0,n-1);
    printf(")");
    cout<<endl;
}
int main(){
    int T = 1;
    while(cin >> n&&n){
        init();
        input();
        printf("Case %d: ",T++);
        solve();
    }
    return 0;
}


UVa348 - Optimal Array Multiplication Sequence

上一篇:Oracle BI Publisher 企业版在WIN7下的安装(BI Publisher Enterprise Edition)


下一篇:LA 3211 Now or later / 2-SAT