【面试笔试算法】Problem 8: 然而沼跃鱼早就看穿了一切(hiho题库)

时间限制:1000ms
单点时限:1000ms
内存限制:256MB

描述

【面试笔试算法】Problem 8: 然而沼跃鱼早就看穿了一切(hiho题库)

fjxmlhx每天都在被沼跃鱼刷屏,因此他急切的找到了你希望你写一个程序屏蔽所有句子中的沼跃鱼(“marshtomp”,不区分大小写)。为了使句子不缺少成分,统一换成 “fjxmlhx” 。

输入

输入包括多行。

每行是一个字符串,长度不超过200。

一行的末尾与下一行的开头没有关系。

输出

输出包含多行,为输入按照描述中变换的结果。

样例输入
The Marshtomp has seen it all before.
marshTomp is beaten by fjxmlhx!
AmarshtompB
样例输出
The fjxmlhx has seen it all before.

fjxmlhx is beaten by fjxmlhx!

AfjxmlhxB

代码:
#include <string>
#include <stdio.h>
#include <iostream>
using namespace std;

int main() {
    string str(201 ,0);
    string t = "marshtomp";
    string s= "fjxmlhx";
    while (getline(cin,str ,'\n'))
    {
        string lowstr = str;
        for ( int i = 0 ; i < str.length ();++i)
        {
            lowstr [i] = tolower(str [i]);
        }
        while ( lowstr.find (t) != string::npos )
        {
            int pos = lowstr.find (t);
            str .replace(pos, t .size(), s);
            lowstr .replace(pos, t .size(), s);
        }
        cout << str << endl;
    }
}

上一篇:scp无密码访问scp -i


下一篇:【面试笔试算法】Program 2:Amusing Digits(网易游戏笔试题)