Not so Mobile UVA - 839

  Before being an ubiquous communications gadget, a mobile was just a structure made of strings and wires suspending colourfull things. This kind of mobile is usually found hanging over cradles of small babies.
Not so Mobile UVA - 839

  The figure illustrates a simple mobile. It is just a wire, suspended by a string, with an object on each side. It can also be seen as a kind of lever with the fulcrum on the point where the string ties the wire. From the lever principle we know that to balance a simple mobile the product of the weight of the objects by their distance to the fulcrum must be equal. That is Wl ×Dl = Wr ×Dr where Dl is the left distance, Dr is the right distance, Wl is the left weight and Wr is the right weight.
Not so Mobile UVA - 839

  In a more complex mobile the object may be replaced by a sub-mobile, as shown in the next figure. In this case it is not so straightforward to check if the mobile is balanced so we need you to write a program that, given a description of a mobile as input, checks whether the mobile is in equilibrium or not.

Input

  The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

  The input is composed of several lines, each containing 4 integers separated by a single space. The 4 integers represent the distances of each object to the fulcrum and their weights, in the format:

Wl Dl Wr Dr

  If Wl or Wr is zero then there is a sub-mobile hanging from that end and the following lines define the the sub-mobile. In this case we compute the weight of the sub-mobile as the sum of weights of all its objects, disregarding the weight of the wires and strings. If both Wl and Wr are zero then the following lines define two sub-mobiles: first the left then the right one.

Output

  For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

  Write ‘YES’ if the mobile is in equilibrium, write ‘NO’ otherwise.

Sample Input

1
    
0 2 0 4
0  3 0 1
1  1 1 1
2  4 4 2
1 6 3 2

Sample Output

YES

HINT

紫皮书上的代码,使用引用的巧妙。代码简短,直接食用即可~

Accepted

#include<bits/stdc++.h>
using namespace std;

int solve(int& W) {
	int W1, W2, D1, D2;
	int b1 = true, b2 = true;
	cin >> W1 >> D1 >> W2 >> D2;
	if (!W1)b1 = solve(W1);
	if (!W2)b2 = solve(W2);
	W = W1 + W2;
	return b1 && b2 && (W1 * D1 == W2 * D2);
}

int main(){
	//ofstream fout;
	//fout.open("temp.txt");
	int T, W;
	cin >> T;
	while (T--) cout << (solve(W) ? "YES" : "NO") << endl << (T ? "\n":"");
}
上一篇:内网-域横向 CobaltStrike&SPN&RDP


下一篇:论文阅读:Deep Image Matting