POJ 2115 C Looooops

C Looooops
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15974   Accepted: 4107

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

Source



扩展欧几里得的最后一题
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
__int64 x,y;
int main()
{
    //freopen("data.in","r",stdin);
    __int64 f(__int64 a,__int64 b);
    __int64 a,b,c,k;
    while(scanf("%I64d %I64d %I64d %I64d",&a,&b,&c,&k)!=EOF)
    {
        if(a==0&&b==0&&c==0&&k==0)
        {
            break;
        }
        __int64 mod = 1;
        for(int i=1;i<=k;i++)
        {
            mod = mod*2;
        }
        __int64 A = c;
        __int64 B = mod;
        __int64 N = ((b-a)%B+B)%B;
        __int64 d = f(A,B);
        if(N%d!=0)
        {
            printf("FOREVER\n");
            continue;
        }
        x = x*(N/d);
        x = (x%B+B)%B;
        if((-x*d)%B==0)
        {
            x = 0;
        }else
        {
            __int64 k;
            k = (-x*d)/B;
            x = x + k*B/d;
        }
        printf("%I64d\n",x);
    }
    return 0;
}
__int64 f(__int64 a,__int64 b)
{
    if(b==0)
    {
        x = 1;
        y = 0;
        return a;
    }
    __int64 d = f(b,a%b);
    __int64 temp = x;
    x = y;
    y = temp-a/b*y;
    return d;
}


POJ 2115 C Looooops

上一篇:单片机学习中的常见问题


下一篇:图文+视频手把手教您:如何增加Excel的可撤消(可撤销)次数