【PTA】7-6 求最大公约数 (40point(s))

求两个整数的最大公约数。

输入格式:
输入两个整数,以空格分隔。

输出格式:
输出最大公约数。

输入样例:
9 18

输出样例:
9

# include<stdio.h>
# include<math.h>
int gys(int a,int b){
    if(a<b){
        int temp=a;
        a=b;
        b=temp;
    }
    while(b!=0){
        int i=a%b;
        a=b;
        b=i;
    }
    return a;
}
int main(){
    int a,b;
    scanf("%d %d",&a,&b);
    printf("%d",gys(a,b));
}
上一篇:【PTA】7-2 求最大值及其下标 (20分)


下一篇:【PTA】7-10 方阵转置 (15分)