C++中的运算符重载——读书笔记

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3211    Accepted Submission(s): 1541


Problem Description

 

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...... 
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you‘ll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 


 

Sample Input

 

2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
 


 

Sample Output

 

YES NO

 

简单二分匹配,求最大匹配数目

#include"stdio.h"
#include"string.h"
#define N 305
int mark[N],link[N],map[N][N],p;
int find(int a)         //匈牙利算法,二分匹配
{
    int i;
    for(i=1;i<=p;i++)
    {
        if(!mark[i]&&map[a][i])
        {
            mark[i]=1;         
            if(!link[i]||find(link[i]))//若i已经配对,则查找和i配对的
			{                   	//那个元素是否还能和其他元素配对             
                link[i]=a;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int t,n,i,a,m,ans;
    scanf("%d",&t);
    while(t--)
    {
        memset(link,0,sizeof(link));
        memset(map,0,sizeof(map));
        scanf("%d%d",&p,&n);
        for(i=1;i<=p;i++)
        {
            scanf("%d",&m);
            while(m--)
            {
                scanf("%d",&a);
                map[a][i]=1;
            }
        }
        ans=0;
        for(i=1;i<=n;i++)
        {
            memset(mark,0,sizeof(mark));
            ans+=find(i);
        }
        if(ans==p)         //最大匹配数等于课程数
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


 

C++中的运算符重载——读书笔记,布布扣,bubuko.com

C++中的运算符重载——读书笔记

上一篇:设计模式(14) 命令模式(Command)C++实现


下一篇:C++编写俄罗斯方块游戏