1061 Dating (20 分)
Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm
. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04
-- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D
, representing the 4th day in a week; the second common character is the 5th capital letter E
, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A
to N
, respectively); and the English letter shared by the last two strings is s
at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.
Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.
Output Specification:
For each test case, print the decoded time in one line, in the format DAY HH:MM
, where DAY
is a 3-character abbreviation for the days in a week -- that is, MON
for Monday, TUE
for Tuesday, WED
for Wednesday, THU
for Thursday, FRI
for Friday, SAT
for Saturday, and SUN
for Sunday. It is guaranteed that the result is unique for each case.
Sample Input:
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
Sample Output:
THU 14:04
题目大意:
给定4个字符串,前两个字符串中找到两对相同的大写字母(两对则意味着两处位置相同的),第一对提供星期且大写字母必须从A~G,因为一星期7天;第二对提供小时数,必须是数字或者字母A~N,对应着24小时制。后面两个字符串提供分钟:寻找相同位置上的相同字母,其位置即为分钟数。
思路:
这种题隐含条件特别多,小心注意即可。
参考代码:
#include<iostream>
#include<string>
#include<cstring>
using namespace std;
char day[7][4] = {"MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN"};
int main(){
string a, b, c, d;
int ans[2];
cin >> a >> b >> c >> d;
int i = 0, j = 0;
while(i < a.size() && i < b.size()){
if(a[i] == b[i] && (a[i] >= 'A' && a[i] <= 'G')){
ans[0] = a[i] - 'A';
break;
}
i++;
}
i++;
while(i < a.size() && i < b.size()){
if(a[i] == b[i] && ( (a[i] >= 'A' && a[i] <= 'N')|| isdigit(a[i]) )){
ans[1] = isdigit(a[i])? a[i] - '0': a[i] - 'A' + 10;
break;
}
i++;
}
while(j < c.size() && j < d.size()){
if(c[j] == d[j] && isalpha(c[j])) break;
j++;
}
printf("%s %02d:%02d", day[ans[0]], ans[1], j);
return 0;
}
代码参考:https://blog.csdn.net/liuchuo/article/details/51985845